Chart node does not show stored data

Hi, sorry I'm new to node-red but i have an issue regarding the chart node.
My "show cloud coverage for the day" does't work even if the data seems good (see debug 1).

The chart just seems empty.

I'm unsure of what exactly is wrong?
My node-red version is3.0.0 and node.js is 16.17.0.

I think the issue may be that you have got the timestamp values in seconds instead of msecs. Try multiplying them all by 1000

I tried multiplying it as you said but the chart is still empty.
Thank you for the suggestion though! (didn't even notice that it was in seconds)

In the debug window hover over the top level object and you will see some little buttons appear, click the one that shows Copy Value and paste the data here using the </> button at the top of the forum entry window when pasting it in. Then select just the chart node, Export it and paste that here too. Then we can try it for ourselves.

Alright I think I got it. Here is the data from the debug windows:


and here is the chart node:

        "id": "3a49a06d33774778",
        "type": "ui_chart",
        "z": "f2d3ee777ce2cd11",
        "g": "fdf4887dbcc7778c",
        "name": "show cloudcoverage for the day",
        "group": "e6c27a5013becd75",
        "order": 11,
        "width": 10,
        "height": 3,
        "label": "Cloudcover",
        "chartType": "line",
        "legend": "false",
        "xformat": "HH:mm",
        "interpolate": "step",
        "nodata": "Let's check how sunny the future is",
        "dot": false,
        "ymin": "",
        "ymax": "",
        "removeOlder": 1,
        "removeOlderPoints": "",
        "removeOlderUnit": "3600",
        "cutout": 0,
        "useOneColor": false,
        "useUTC": false,
        "colors": [
        "outputs": 1,
        "useDifferentColor": false,
        "className": "",
        "x": 890,
        "y": 360,
        "wires": [
        "id": "e6c27a5013becd75",
        "type": "ui_group",
        "name": "Weather/Sunset/Sunrise",
        "tab": "afeab48796dd45c9",
        "order": 2,
        "disp": false,
        "width": 10,
        "collapse": false,
        "className": ""
        "id": "afeab48796dd45c9",
        "type": "ui_tab",
        "name": "Main Menu",
        "icon": "fa-bars",
        "order": 2,
        "disabled": false,
        "hidden": true

Your x and y are capitals, make them lowercase.

Yes! This was it. Now it works perfectly. Thank you!!!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.