Charts on UI are freezing

I just started with NodeRED and IOT 1 week ago.
I'm running Siemens IOT2040 device connected to a PLC.
I programd a seconds counter in the PLC - integer changing from 0 to 60 each sekond.

Then I tried the UI in my NodeRED on IOT2040.
But I can see the chart is freezing from time to time, actually very often.
The data is GOOD because I put a Gauge with teh same integer data and it is updating without any problems.
Is the chart object a known problem or there is another problem/fail ?

Thank you !

P.S I made quite a 'big' flow just to get the counter to many objects.
Could that be the problem ?

That is a very small flow so shouldn't be a problem.
When you see a gap appearing does the chart move along putting zero values in or does it freeze and then jump forwards when it starts again?
What versions of node-red, node-red-dashboard and nodejs are you using? The startup log from node-red should show you that.

Also, can you check if your browser is using a lot of CPU time and/or RAM? Those charts can get quite heavy the more points are added to them.

I cleaned most of the Flow so I just made 2 tabs with a Chart and Gauge on each.
Both showing the same Sinus curve.
The charts were working for a while but they stopped after a short time - some minutes.
I see the value on the charts is 0 but the time is running so it is updating.
Is that the NodeRed version you see on one of my screenshots ?

You see the gauge is showing the values but not the charts.

How much data is coming out of that PLC node? If it's a lot (i.e. more than the number of pixels that graph consumes), consider putting an RBE node before the chart node or a limit on the number of messages like 2/sec).

It might be that the same value is coming thick and fast (so it looks like a straight line) but is too much too fast for the chart?

Just an idea.

What version of nodejs is it using? In a terminal run
node -v
You can see which version of the dashboard by looking in Manage Palette.
When the line is stuck, is the end of the line moving right regularly or does it not move for a bit and then jerk forwards?
Also, as Steve asked, how often is data being given to the chart?

My data is updating each 1000ms.
But anyway Thnak you! I put a RBE function to update data on change.
It was working again for a while, but then Chart stopped and showed line with value ZERO.
Tha time scale is moving anyway.
My data is sinus curve Sinus of 0 to 2xPi and the value is changing from -1 to 1.
You can see on the pictures it works fine in the beginning.

My dashboard nodes ar a bit oldre V2.15.5 but I'm having problem to update those drom the
Pallet manager.
You can see the error on the other picture I have attached.

What more could be wrong :frowning:

It is always better, if possible, to copy/paste log output rather than a screenshot, it is much easier to read and reference. It looks as if you have some special hardware specific nodes installed which are causing the problem with updating. I don't know anything about that device. It might be a good idea to start a new thread requesting help with updating. Put the device name in the thread title then hopefully someone who knows will be able to help.

I have a Siemens IOT2040 module communicating with Siemens S7-1200 PLC.
You see it's version of Node-Red on my screenshots. I tried to upgrade but nothing changed.
My PLC is making a simple calculation each second and IOT2040 is reading the value each
second has a variable reading the value from the PLC. I also made a node-der node that is
filtering the update of the value to the chart to 1sek.
I'm reading the same value on a Gauge dashboard component, you can also see it on my
You can see the Chart drawing freezes after a while, but the Gauge is still showing the data from the PLC.
That makes me think that the Chart is not working properly for some reason.
I made a function in Node-red to fix my floating point number to just 2 decimals after coma, but that didn't help much.

I'm not sure that I mange to describe the problem correctly, because it seems you don't understand me. The roblem is somewhere in the Dashboard and the Chart. As I'm using 2 components Chart and Gauge to visualize my variable, and just one of them is FAILING it should be a problem of the 'ui' or the chart.
I already posted a screenshot of the errors when I tried to upgrade the Dashboard from 2.15 to 2.21 if that could help.
Please explain to me which log is interesting to see. I'm quite new and not sure where and which log can help for debuging.

I suspect your package lock file is corrupt. You could try inspecting & repairing it but might be difficult to find the issue.
However, if you're feeling adventurous & you're willing to try, you could try the following...

  1. ssh to the box
  2. Stop node-red
  3. Cd to node-red folder
  4. Rename package-lock.json to package-lock.json.orig
  5. Rename node_modules folder to node_modules_orig
  6. npm install
  7. Start node-red

If it works - great. If not, you can always revert.

Ps, backup your flows too just in case.

Lastly - is there any real reason for having the Siemens box? If you don't use any nodes proprietary to that box then a raspberry pi, mini PC/nuc or a server VM could easily replace it & then you could use current LTS nodejs (and the S7 nodes work well on regular hardware)

I think we understand the problem, but I do not remember seeing it reported before so something is unusual about your system. One problem is that you are running on unusual hardware and for some reason you are not able to upgrade to the latest versions so it is difficult to know what might be going on.

Thank you for the suggestion.
I will try that in the evening, but I need some more information.

  1. ssh to the box - what you mean here ?
  2. Stop node-red - that is OK
  3. Cd to node-red folder - that is OK
  4. Rename package-lock.json to package-lock.json.orig - Should be OK
  5. Rename node_modules folder to node_modules_orig - Should be OK
  6. npm install - you can see my Node-red version from my previous post. Is taht the last one or I need to update it somehow, before or after installing?
  7. Start node-red - OK

I read some place advise to use Firefox browser. I'm using Chrome, can this be the reason for my Chart Dashboar Node is freezing after a while?- I don't think so, but need to ask :slight_smile:

Thank you !

  1. ssh to the box - what you mean here ?

Connect to the terminal / command prompt (I assumed you telnet / ssh to the box for a command line interface)

  1. npm install - you can see my Node-red version from my previous post. Is taht the last one or I need to update it somehow, before or after installing?

npm install doesnt do what you think (it doesnt install nodejs or node-red) - npm install tells NPM to look inside the package.json file and install everything listed in dependencies{}
So in other-words, because on step 5 you (sorta) deleted the node_modules folder (well renamed it out of the way) it downloads all the node_modules again - i.e. updated versions (including your goal of getting latest dashboard node)

chrome works fine for me

Hi, Steve!
I kulled Node-red, run the commands as you suggested, but now I experiencie difficulties to start Node-red again.
I have restarted my device many times and ran some start commands I found on the net about IOT2040 from Siemens. But no luck :frowning:
Do you have some Idea what can I do next ? node-red start 1

I'm not sure start node-red is correct?

What happens if you try node-red or node-red-start?

I don't know how Siemens arranged the install on that custom box - you might need to ask in a Siemens forum.

I do know one thing, if I was using purely for node-red, it'd be heading for the bin - terrible support - they should be releasing firmware for it to replace the EOL nodejs version at minimum.

Thank you Steve!
I will wait for respons from Siemens support forum
Or if not, I will rewrite my SD card and start over :frowning:

Thanks for now!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.