Connection failure

Hi guys,

Feeling dumb this morning and confused by the time change. Got to work and my node-red refuses to connect, not sure why. I've started it back up the way I normally do, in fact it usually fires right up when I come in, but this morning I can't get it to go.

I've stopped my mosquitto broker and rerun it, using these commands:
And I've closed node-RED and rerun it but opening CMD as admin and typing "node-red" but I get this error:

I've restarted my pc, had my coffee, and walked around to clear my head on it, still no dice- any indications here on what I'm doing wrong?

Did the IP address of the device running the MQTT broker change?

1 Like

In particular, is the broker running on the same machine as node-red? I ask because the node red startup says it is running on, but it is trying to connect to a broker at 1.89

1 Like

Now I really feel silly! Yup, looks like all our IP addresses shifted over the weekend for some reason. I've updated Node-RED config nodes and the PLC and now things are working again. Thanks y'all!

If it is running on the same machine then use localhost instead of the ip address, then it will always work.

1 Like

Nice tip, thanks Colin! Now if only the PLC had a setting like that.. lol

I think you need to find out why the IP addresses changed. Talk to your IT guys and work out what is going on. Either you need fixed IP addresses or you need to use host names. The IT dept should be able to advise you.

1 Like

We weren't able to determine why the IP addresses changed but I did configure static IP on the machine running my broker as well as the PLC, we're working on getting the PLC and broker to the cloud now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.