Controlling Schneider SE8000 with nodered modbus

Hello,
We are trying to communicate, read and control the Schneider SE8000 with modbus (room controller for HVAC Fan Coil applications) using the library node-red-contrib-modbus, but I cant even read the input or coil status. Someone already did this or something similar to help?
I tried to upload the modbus integration guide attachments but new users cant upload any file, so I'm leaving some links to you know what device it is.
[link 1 to installation guide](II-SE8300-A4.PDF (schneider-electric.com))
Link 2 to User Interface guide

Hello ..
link 2 is down .. from link 1 that you have shared it seems that your device is using BACnet protocol instead of Modbus. (unless you have shared the wrong manual)

If its indeed Bacnet maybe look into this node instead

Hello!
No no, we are using Modbus, I've just uploaded the manual so everyone can see wich model it is, I'll send pictures of the device and modbus node configuration for you soon as I can.

Hello! Follow attached pictures from the device configuration.
Following this configuration, how can I configure the node to read and control it? I tried so many ways and configuration and none has worked (I'm new at nodered)


and the settings of your Modbus configuration node ?
have you confirmed that the baud rate, parity, device id match
and the polarity of the RS485 connection wires ?

Hello,
We are sending pictures of the node (blank) that we are using.
PS: We'll reply with two more pictures because new users cant upload more than 2 media files at once


Hello,
Follow the 2 extra pictures of the configuration


Hi .. i think what Schneider calls COM Address must be the device's Modbus Unit-Id address

image

Have you tried filling in the node's config the number 5 for the Unit-Id

Also what OS are you using for your Node-red system ? Is it on Windows
What device are you using on the Node-red system in order to use Modbus ?
a USB to Serial converter ? something else ? Can you confirm this device is on COM5 ?

Hello,
Yeah, we tried to put 5 on the Unit-Id.
Answering the other questions:
Windows? Yeah, Windows 10.
We're using an Serial converter/USB device from "Mercato automação" (link below), and yes, it is on COM5 when the driver is identified.
We'll run another test today so I'll fill the next topic with more pictures and info, maybe we'll try to to a different connection on the D+ and D- of the converter, now we are connecting + (SE8000) to + (Converter) and - (SE8000) to - (Converter)
Follow Link below.

Hello,
On quantity, its the qtd of coils that I want to control, right? So, in this case its 1.
In the "Address" field, I put the Modbus Address Command that I want to sent, right? For example, to read room temperature I would put 30001:


modbus mapping

Yes .. thats correct

yes .. the address that you want to read or write to

try 30001 but if that doesnt work also try Register 1 and in Function Code 4
(as stated in the Modbus Register column in the table you shared)

Hello,
We tested with both configuration and it failed, and also have identified a problem with a connection from the node to the port, it keep appearing the message "Reconnecting" every time. Soon I'll upload the video

Do you see any activity on the TX/RX LEDs?

You might want to invest in something like https://fte.com/products/serialanalyzers-rs422485.aspx to verify the data is making it to / from the device.

Alternatively, connect a virtual serial port COM9 to COM5 and communicate from node-red to COM9 - use the Virtual Tool to analyze serial comms traffic.

Along with Steve's suggestions ..

  1. can you also try to read using a seperate Modbus Master software to see if the reconnection issue is due to the node or something else.

QModMaster (link)

image

  1. What version nodejs are you running on your Windows system?
    Note that the latest 5.21.2 version of Modbus nodes support up to Nodejs v14
    (connection issues were reported on Github with anyting higher)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.