Could someone please tell me if they can get this node installed and fully working?

I feel I have to ask.

I am really not getting anywhere and am starting to clutch at straws to find out why it won't work now.


I am installing it from the CLI and it is complaining that it can't find the required libraries.
(Yes, I know...)

I ran this command before doing the install.
curl -sS | bash

I don't know if it needs to be done by sudo or not. Does it need the FULL install?
(That's 4 possibilities already)

But I have run that command to meet the prerequisites and when installing the node it says it can't find the libraries: something is wrong - somewhere.
Oh, and YES: I did reboot.

It was working on the release just before BUSTER.
While updating the power was lost and so the card won't boot.
It isn't corrupt, but just won't boot.

To further test/try to find a solution I tried both STRETCH and JESSIE (old SD cards lying around)
Did the prerequisite. Installed the node from the CLI.
"Can't find the required libraries."

This is frustrating as everything needed is on the original SD card that now won't boot.
So at a pinch, I could copy them from it to the new SD card.

But I don't know enough about how to find the required library names.

All I am asking is if someone could confirm that they can install this node and get it working with BUSTER, and HOW they did it.


When I try to install the node this is what I see:

pi@MusicPi:~/.node-red $ npm install node-red-node-pi-neopixel

> node-red-node-pi-neopixel@1.0.0 postinstall /home/pi/.node-red/node_modules/node-red-node-pi-neopixel
> scripts/checklib.js

WARNING : Can't find required python library
WARNING : Please install using the following command
WARNING : Note: this uses root...
WARNING :    curl -sS | bash

+ node-red-node-pi-neopixel@1.0.0
updated 1 package and audited 166 packages in 7.675s

9 packages are looking for funding
  run `npm fund` for details

found 15 vulnerabilities (7 moderate, 7 high, 1 critical)
  run `npm audit fix` to fix them, or `npm audit` for details
pi@MusicPi:~/.node-red $ 

So given I have done that curl -sS | bash command already....

What's my next option?

Because I like to share - but still don't understand what is going on.

Messing around in /boot/config.txt.

These lines were added (and rebooted)

hdmi_force_edid_audio = 1

Now the NEOPIXELS work.

So to me it raises a lot of questions.

When I was installing the node it was saying
WARNING : Can't find required python library
(end quote)

I did NOT install any other libraries in the mean time.

But I added those lines to the /boot/config.txt, rebooted and they now work.

What's going on?

Please, someone who understands what is going on.


You've got it working - lets stop :slight_smile:

Well, to me the question remains:

Why does the node say "I am missing python libraries I need to work" ?

There is a big problem there.

I lost 4 weeks chasing this.

I would like to know the REAL reason behind what caused it.

Unless you are the first person to discover a bug in the install routine (and that's always possible) it's most likely that your not quite fully following the required instructions to install all the software needed to drive the neopixels

Until, someone else here does a brand new install, we won't find out which it is.

Please let it rest here :slight_smile:

I am asking someone (maybe even @knolleary or @dceejay) to look into why I was seeing an erroneous message.

Had it said: "You need to edit the config.txt file and tell me the needed lines I need to add", then yes, I'd leave well enough alone.

But that it said such a misleading message. Nah, my OCD just won't let it be.

Some of the 5 lines I mentioned were kind of hinted at in other threads I was reading.
Or it was implied that the changes would be applied by the script.

But the others. No mention of their use or WHY they need to be included.

Ok, there is a line between those who wrote the O/S and those who made the node and where the responsibility lies.

I'm NOT in anyway blaming anyone.
But please. I can't leave it alone after all this time.

Or someone to install the node and tell me if they get it working "out of the box" with instructions as written.

I've tried with two other releases (Jessie and Stretch). They also didn't work now.
So maybe something..... anyway.

Because if they can't that is another reason it needs to be looked at/into.

Andrew, if you go to the node’s page node-red-node-pi-neopixel (node) - Node-RED you will see that the pre-requisite to installing the node is to run the curl command which will install some libraries.

Those are probably the libraries that were missing. If you ‘have to know’, then flash a new SD card with Buster and run the ‘curl’ command `before installing the node and see what happens.

It’s always a good idea to review the node read me before installing it and following the directions.

But they aren't!

All I did (eventually) to get it working is add those 5 lines in the /boot/config.txt file.

I don't know why I picked them 5 lines. Some were vaguely familiar to me from other posts and the other 3.... Sheer luck.

To recap:

I did the curl -sS (blah blah) command.
I even did it without the -sS. No errors seen.
So as far as I can with respect to that: It worked.

But when I tried to install the node AFTER doing that - and rebooting I shall re-state - it (the node while installing) said it was missing the libraries.

I have to find time and see if it is simply one of the 5 lines or what permu... combination of the five lines are causing the problem.

I just got the old SD card, and looked at the file.

The lines HOOKED me. I copied them, put them in/on the new SD card's config.txt file and rebooted.

VOILA! The LEDs worked.

I didn't install any libraries in the mean time.

So there is MORE going on here than is claimed.

And you rebooted, right? If you want to see if those five lines fixed it, remove them, reboot and see if the node runs. Those lines shouldn’t effect the node and if one did it would probably be the uart one.

I shall.

But those 5 lines and a reboot...... They started working.

So SOMETHING in what they do is having a HUGE effect on the node's functionality.
And NOTHING to do with Missing libraries that were reported to me when I was installing (or trying to) the node.

(This is about 4 weeks old and a lot of time invested in trying to get it working)

Ahh, there is a note on the GitHub page for the unicorn that says

Important Notice

Because Unicorn HAT uses the PWM hardware, which is also how your Raspberry Pi generates analog audio, you may see random colour patterns and flickering.

If this happens, you should add the following to your /boot/config.txt:

Sound will work fine using speakers on, for example, an HDMI TV, but you will not be able to use your Pi's 3.5mm audio jack in conjunction with Unicorn HAT.

So it could be that line that fixed it for you. See GitHub - pimoroni/unicorn-hat: Python library for Unicorn pHAT and HAT. 32 or 64 blinding ws2812 pixels for your Raspberry Pi

Yeah, that's 1 of 5 lines.

I also remember something about the hdmi_force_edid_audio = 1 line too.

But no mention of the other 3 lines.

I've been in front of the machine for about 14 hours today.

Screenshot from 2022-02-23 22-16-54

Given I'm given time to eat and excrete.

When I get a moment tomorrow, I will go through the combinations of the 5 lines and see which are causing the problem.

Don’t you mean ‘see which is solving the problem’ :laughing:

That too.... But I won't stop with just one.

I'm going to try all combinations. In for a penny....

Seems the only 2 lines needed are the ones:

hdmi_force_edid_audio = 1
1 Like

Thanks @dceejay.

But the question still kind of remains: why is it that when I was installing the node it was saying there ARE libraries missing?

If you remove those lines again do you still get the same error?

Well, I don't get the same.... ERROR. The LED's just don't work.

The machine boots, everything else works. Just not the LEDs.

So it would seem they are curtial (why can't I remember how to spell that?) (important) to the LEDs working.

But I remember reading that those would be set by one of the install scripts. (Probably the first one).

So much for trusting what install scripts say.

So what did you do that made the libraries error go away?

AFAIK they haven't been resolved.

The node is installed. I see it in the node list, and it works.
But if those libraries aren't there or not.... I don't know.
Because they aren't named either so it is also difficult to know.