Neopixel node does not send out signal

Dear all,

i am trying to control a WS2812B ledstrip with the neopixel node.
i am using a raspberry pi 3B with 2022-01-28-raspios-bullseye-armhf and node red version 2.2.2.
i followed the instruction of installing the unicorn hat as suggested on node-red-node-pi-neopixel (node) - Node-RED
but i am not able to get it to work.
everything seems ok but it looks like the output signal is nog set to the giopin.

if i flash a old project with 2017 versions on the sd card using the same hardware it works.

does anybody know what the issu can be?

here some more information about the project that is not working.

Start Node-RED

Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser

Use node-red-stop to stop Node-RED
Use node-red-start to start Node-RED again
Use node-red-log to view the recent log output
Use sudo systemctl enable nodered.service to autostart Node-RED at every boot
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to

Starting as a systemd service.
6 Mar 12:47:46 - [info]
Welcome to Node-RED

6 Mar 12:47:46 - [info] Node-RED version: v2.2.2
6 Mar 12:47:46 - [info] Node.js version: v14.19.0
6 Mar 12:47:46 - [info] Linux 5.10.92-v7+ arm LE
6 Mar 12:47:47 - [info] Loading palette nodes
6 Mar 12:47:51 - [info] Settings file : /home/pi/.node-red/settings.js
6 Mar 12:47:51 - [info] Context store : 'default' [module=memory]
6 Mar 12:47:51 - [info] User directory : /home/pi/.node-red
6 Mar 12:47:51 - [warn] Projects disabled : editorTheme.projects.enabled=false
6 Mar 12:47:51 - [info] Flows file : /home/pi/.node-red/flows.json
6 Mar 12:47:51 - [info] Server now running at
6 Mar 12:47:51 - [warn]

Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

6 Mar 12:47:51 - [info] Starting flows
6 Mar 12:47:51 - [info] Started flows
pi : PWD=/home/pi ; USER=root ; COMMAND=/usr/bin/python3 -u /home/pi/.node-red/node_modules/node-red-node-pi-neopixel/ 24 40 pixels 100 true 0 18
pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)

Dear All,

i think the issu comes from the python script behind it.
i am getting this error if i try to run it.

does anybody know how to fix it?

Hi Nick.

I have been down this road a few times. Recently as well.

Did you do the other (pre-requisite) part:


The Neopixel python driver need to be pre-installed... The easiest way to get the driver installed is to use the Unicorn HAT drivers install script... see the Pimoroni Getting Started with Unicorn HAT page.

curl -sS | bash

The other thing that can cause you grief if the /boot/config.txt file.

There are things in there what MUST be set.

My journey into th NeoPixel world.

You need these 4 lines to be as shown:

hdmi_force_edid_audio = 1

Though people will argue it is only the first two, I have recently found that the last two are also needed.

Thank you for your replay.
the unicornhat i already had installed sow i also added the 4 lines to the config.txt

but it is still not working.

any other suggestions?

is it maby possible for you to share a .img file with buster and the working neopixel node?

.img file?

Ok, I'd better take a step back....

Have you ever had the LED strip working or is this THE first time?

When you double click on the NEOPixel node, have you set the GPIO pin to use?

The error you posed is probably because you may have sent it a value for an LED which is out of range.

Put a debug node beside the noepixel node and capture the entire message and post it here.

By the way, how many LEDs are in the strip?

And WHICH strip is it?

Lastly: Double click the Neopixel node and take a screen shot and post it here.
If you can: crop it so the edit window of the node is all you post.
Makes it bigger and easier to see/read.

Oh, something else:

In a terminal (CLI) enter:
sudo raspi-config and make sure the interfaces are active.
Because if they aren't (or at least the one needed for it to work) isn't...

I can't say which one it is, but activate them all and work backwards from there.

with the .img file i mean the image of your sd card with the working neopixel node.

yes i had it working in the past as i described in my first commend but this was in 2017.
sow a lot of new versions came out.
if i try a old project it is working.

Have you made sure all the interfaces are enabled via the raspi-config?

I live in Australia. I am not going to upload a 65G sd card image.
Partly because it will take forever and I am not going to sit down and remove all the personal stuff before I would do it anyway.

I can't help you any further with it.

But I can tell you that I went through a lot of problems/pain to get it working.

The biggest thing that was the problem was the 4 lines I showed you in the /boot/config.txt file.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.