Cron_Plus vs Bigtimer - times given are different

With recent events, I have been introduced to Cron_Plus.

Until recently (well When I first wanted to do this Bigtimer was the goto node as it offered sunrise/set/etc times.

You enter the Lat/Long and all is done.

So, here's the problem:

I have bigtimer set up for sunrise/set times.


[{"id":"78bece90.f1aca8","type":"bigtimer","z":"c636aa5a.cc34","outtopic":"DAYTIME","outpayload1":"SUNRISE","outpayload2":"SUNSET","name":"Day Start/End","lat":"-33.51","lon":"151.12","starttime":"5003","endtime":"5004","startoff":0,"endoff":0,"offs":"0","outtext1":"Sun rise","outtext2":"Sun set","timeout":1440,"sun":true,"mon":true,"tue":true,"wed":true,"thu":true,"fri":true,"sat":true,"jan":true,"feb":true,"mar":true,"apr":true,"may":true,"jun":true,"jul":true,"aug":true,"sep":true,"oct":true,"nov":true,"dec":true,"day1":0,"month1":0,"day2":0,"month2":0,"day3":0,"month3":0,"day4":0,"month4":0,"day5":0,"month5":0,"d1":0,"w1":0,"d2":0,"w2":0,"d3":0,"w3":0,"d4":0,"w4":0,"d5":0,"w5":0,"suspend":false,"random":false,"repeat":true,"atstart":true,"odd":false,"even":false,"x":290,"y":110,"wires":[["bdfd1901.fa4e6","5f3c122b.53cd64"],["5a9aa6df.bc03c8","2fff825f.4c298e","bc2f9e5d.e193c8","419764dc.3b0cac"],["f57f811c.4641d8","d8c5c8aa.893d8"]]}]

The output says Sunset is 19:54 today. Which is pretty close to what other sources say.
And I'm guessing those times are for the timezone, not my exact longitude.
Which is what I am guessing Bigtimer is giving me.

Anyway, Cron_Plus has become of interest because it has some features I think are nicer than Bigtimer's.

So, I set things up for SUNSET. Enter Lat/Long via its map.
Sunset: 18:35

[{"id":"a3f53c75.bc923","type":"cronplus","z":"b25fd092.bcc758","name":"Day Start / End","outputField":"payload","timeZone":"","persistDynamic":true,"commandResponseMsgOutput":"output1","outputs":1,"options":[{"name":"Dawn","topic":"schedule1","payloadType":"str","payload":"Dawn","expressionType":"solar","expression":"0 * * * * * *","location":"33.88094790268725 -208.87731456743495","offset":"0","solarType":"selected","solarEvents":"sunrise"},{"name":"Dusk","topic":"schedule2","payloadType":"str","payload":"Dusk","expressionType":"solar","expression":"0 * * * * * *","location":"33.88094790268725 -208.87731456743495","offset":"0","solarType":"selected","solarEvents":"sunset"}],"x":2010,"y":510,"wires":[["a9dfb0d5.092938"]]}]

That's about 90 minutes difference.

Could someone explain what I am missing?


This is interesting:

How I scrolled to where I am I went the wrong way and the LONG was -208.... something.
(Which can't exist)

I scrolled the right way and got it to 151.

Now when deployed the sunset time is 19:55 which is more acceptable.

New node/code

[{"id":"a3f53c75.bc923","type":"cronplus","z":"b25fd092.bcc758","name":"Day Start / End","outputField":"payload","timeZone":"","persistDynamic":true,"commandResponseMsgOutput":"output1","outputs":1,"options":[{"name":"Dawn","topic":"schedule1","payloadType":"str","payload":"Dawn","expressionType":"solar","expression":"0 * * * * * *","location":"-33.88050254877312 151.12279272092562","offset":"0","solarType":"selected","solarEvents":"sunrise"},{"name":"Dusk","topic":"schedule2","payloadType":"str","payload":"Dusk","expressionType":"solar","expression":"0 * * * * * *","location":"-33.88050254877312 151.12279272092562","offset":"0","solarType":"selected","solarEvents":"sunset"}],"x":2010,"y":510,"wires":[["a9dfb0d5.092938"]]}]


Are you sure that you are comparing like for like?
Should Cron+ be set to 'Astronomical Dusk' and not 'Sunset'. That would give almost the same time as Bigtimer, give or take a few minutes.

I posted the two versions of the node as I have it set in the flow.

Just to keep things declared.

Did you see/notice that the LONG value was -208 and when I changed it to 151 it now shows the correct time?

Could you please test this on your machine.


Hang on!

Caught it!


[{"id":"8e408a43.98b6f","type":"cronplus","z":"b25fd092.bcc758","name":"Day Start correct LONG value","outputField":"payload","timeZone":"","persistDynamic":true,"commandResponseMsgOutput":"output1","outputs":1,"options":[{"name":"Dawn","topic":"schedule1","payloadType":"str","payload":"Dawn","expressionType":"solar","expression":"0 * * * * * *","location":"-33.88050254877312 151.12279272092562","offset":"","solarType":"selected","solarEvents":"sunset"}],"x":2050,"y":950,"wires":[[]]},{"id":"ced55acd.52e64","type":"cronplus","z":"b25fd092.bcc758","name":"Day Start / End","outputField":"payload","timeZone":"","persistDynamic":true,"commandResponseMsgOutput":"output1","outputs":1,"options":[{"name":"Dawn","topic":"schedule1","payloadType":"str","payload":"Dawn","expressionType":"solar","expression":"0 * * * * * *","location":"33.88094790268725 -208.87731456743495","offset":"0","solarType":"selected","solarEvents":"sunrise"},{"name":"Dusk","topic":"schedule2","payloadType":"str","payload":"Dusk","expressionType":"solar","expression":"0 * * * * * *","location":"33.88094790268725 -208.87731456743495","offset":"0","solarType":"selected","solarEvents":"sunset"}],"x":2030,"y":1020,"wires":[[]]}]

So was the problem that you selected the wrong lat/lon coordinates.

Well, that's a good question.

I scrolled the globe ..... left rather than right to get where I am.

I got a longitude of -208.

The program (node?) accepted it.

That gave/gives me the wrong time.

Do you get the same results if you import the code I posted?

I didn't enter the wrong values.

The Map gave me the wrong values.

Yes, the two different longitudes gave me different times. I deleted them when you said 'Caught it', so can't tell you what they were.

Yes, the longitude isn't properly constrained:


It should reset at 360 surely? Possibly at 359.99?

Keep going East ...




Also hope that you don't want to select the north pole or the south pole


Yes, its true, I'm running out of good YouTube video to watch!!


Wouldn't it be 180 not 360? (+/- 180)

Just saying.

The nodes have the LONGITUDE in them.

Caught it was more that I had caught the error as I had erroneously said the problem had stopped - when it hadn't.

And I then showed it.

Sorry for the confusion.

Haha, a long time since my geography lessons obviously! :grimacing:

Or maybe its because the world really IS flat?! :see_no_evil: :hear_no_evil: :speak_no_evil: :world_map:

1 Like

I guess I've never scrolled far enough east or west (or noticed). Suprised the map component allows this. I'll check it out some time this week.


It isn't I wanted to find a bug, but just my usual Playing outside the box methodology found it.

Let's not forget that Andrew is in Australia, so the world will rotate in a different direction to us in the northern hemisphere...


I've been there, and it is true!

The hardest part to get used to is hanging on with your arms so you don't fall.

(We are upside down here.)



This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.