Dashboard 2.0 update/install failed

Hi there,

I have a Nodered install for tests in which I was testing dashboard 2.0.
I tried to upgrade to version 1.1.0 using the "manage palette" menu, and pressed the "update" button. I had a success report and a warning message to restart Nodered, which I did.
After restart I had some error messages about unknown nodes (previously used dashboard 2.0 nodes).
Checking the palette, dashboard 2.0 was no more installed.

I then tried to reinstall, but I got this error message in the log:

2024-02-09T16:37:51.393Z Install : @flowfuse/node-red-dashboard 1.1.0

2024-02-09T16:37:50.452Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @flowfuse/node-red-dashboard@1.1.0

2024-02-09T16:37:52.609Z [err] npm

2024-02-09T16:37:52.611Z [err]

2024-02-09T16:37:52.612Z [err] WARN config production Use --omit=dev instead.

2024-02-09T16:38:00.513Z [out]

2024-02-09T16:38:00.513Z [out] up to date in 8s

2024-02-09T16:38:00.569Z rc=0

Any idea how to solve that?
Thanks a lot,

rc (return code) zero means "success"

In short, I do not see any issue here.

Have you refreshed your browser?

Can you restart Node-RED then refresh your browser once more please?

After that, can you show us what you see in "installed" modules on the palette manager and what if any errors you have in the editor.

I did a nodered restart and browser refresh.
In the palette, the nodes tab shows nothing, whereas in the install tab I can still flnd @flowfuse/node-red-dashboard. I can press the install button but here is what I got after trying to install :

Log message is the same as in the previous post.


  1. What version of nodejs & node-red are you running on?
  2. can you try to install the dasboard using command line
    • stop node-red
    • cd to your .node-red dir
    • run npm -i @flowfuse/node-red-dashboard
    • show us what you get (text, not image, surrounded in a code block for formatting)
    • start node-red

I think that should be just i not -i.

1 Like

Node-red: version 3.1.3
Nodejs: v18.19.0

izno@lepotato:~/.node-red$ npm i @flowfuse/node-red-dashboard
up to date, audited 241 packages in 7s
33 packages are looking for funding
  run `npm fund` for details
found 0 vulnerabilities

after nodered restart, it was still not installed in the palette.

So I checked the directory .node-red/node_modules/@flowfuse/node-red-dashboard and the directory existed.
I made a manual npm uninstall, then node-red-restart then npm install again.
After node-red-restart, now the nodes show up in the editor !

Problem solved, but don't know why :wink:
Maybe something conflicted during the initial "update" process.

Anyway, thanks for your help !