Dashboard option not coming in Node-RED after update


#1

I am not able to see Dashboard option even after updating node-red multiple times. I am just trying to create a Simple HMI for a LED on/off using raspberry PI


#2

Do not you come to the page or nothing is displayed there?


#3

When you say you can't see the dashboard option does that mean

  1. You don't see any of the dashboard nodes on the left hand side?

  2. When you create a flow that includes a dashboard node (and configure it) you don't get website displayed at the link?

If your answer is 1) How did you install the nodes? Were there any error messages?

Make sure you have node-red-dashboard installed and have NOT installed any other nodes that include dashboard ( eg mdashboard)
What version of Node-RED, dashboard and nodejs have you got installed? (Check the start-up messages for node-RED)


#4

My problem is Option 1.

This is the message i get when i update my node-red
Running Node-RED update for user root at /root

This can take 20-30 minutes on the slower Pi versions - please wait.

Stop Node-RED :heavy_check_mark:
Remove old version of Node-RED :heavy_check_mark:
Remove old version of Node.js -
Leave existing Node.js - Node v8.11.2 Npm 5.8.0
Clean npm cache -
Install Node-RED core :heavy_check_mark: 0.19.5
Move global nodes to local -
Install extra Pi nodes -
Npm rebuild existing nodes -
Add shortcut commands :heavy_check_mark:
Update systemd script :heavy_check_mark:

Any errors will be logged to /var/log/nodered-install.log

All done.
You can now start Node-RED with the command node-red-start
or using the icon under Menu / Programming / Node-RED
Then point your browser to localhost:1880 or http://{your_pi_ip-address}:1880

Started Thu Jan 3 22:41:36 EST 2019 - Finished Thu Jan 3 22:42:13 EST 2019

Is there anything else I have to do other than updating node-red to see the dashboard


#5

This is the message i get when i install node-red-dashboard

root@kali:~# npm i node-red-dashboard
npm WARN saveError ENOENT: no such file or directory, open '/root/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/root/package.json'
npm WARN root No description
npm WARN root No repository field.
npm WARN root No README data
npm WARN root No license field.

  • node-red-dashboard@2.13.0
    added 58 packages from 49 contributors in 11.105s

and this is the web page


#6

if you go into the manage palette, then node-red-dashboard appears under installed?
how do you install the dashboard via the console or via manage palette


#7

via terminal.


#8

there is very little reason to run Node-RED as root rather than as a user with normal privileges.

You appear to be installing the dashboard in the wrong directory. You should be in your .node-red directory

But please reconsider running as root unless you have a specific reason to do so


#9

Thanks. I tried installing dash board using manage palette. it worked.


#10

Are you planning on accessing the dashboard on the internet? If so you have to follow the instructions to secure both Node-RED and the dashboard there are examples of people looking for insecure Node-RED instances to mine cryptocurrency


#11

No. I am trying to run in my local machine.


#12

Did you install as user root for a reason? That is generally not a good idea. Much better to log on as the normal user (pi?) and run the upgrade script as that user.

Colin


#13

Thanks for pointing that out. I will reinstall Node-red with less privilaged user.