Dashboard only showing Welcome

Hello all,

I 've a problem getting the node-red dashboard working.
I did a new installation on ubuntu server 18.04 LTS.
node-red is working fine. I entered and configured a "switch"-node and a "text-input"-node. Configured the dashboard settings and deployed the config.
When I open or refresh the page http:localhost:1880/ui, ther is only a white screen showing: "Welcome to the Node-ReD Dashboard" Please add.......

I restarted my node-red and looked at the node-red-log (see beneath)
Can't see what is going wrong,
Can anybody help me get this thing going.
NOTE: I'm not a Linux specialist (just a beginner ;-), so please guide me with clear instructions.
Thanks in advance

Welcome to Node-RED

18 Mar 18:56:26 - [info] Node-RED version: v1.0.4
18 Mar 18:56:26 - [info] Node.js version: v13.11.0
18 Mar 18:56:26 - [info] Linux 4.15.0-91-generic x64 LE
18 Mar 18:56:26 - [info] Loading palette nodes
18 Mar 18:56:27 - [info] Dashboard version 2.19.4 started at /ui
18 Mar 18:56:27 - [info] Settings file : /home/guido/.node-red/settings.js
18 Mar 18:56:27 - [info] Context store : 'default' [module=memory]
18 Mar 18:56:27 - [info] User directory : /home/guido/.node-red
18 Mar 18:56:27 - [warn] Projects disabled : editorTheme.projects.enabled=false
18 Mar 18:56:27 - [info] Flows file : /home/guido/.node-red/flows_homesrv.json
18 Mar 18:56:27 - [warn]

Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

18 Mar 18:56:27 - [info] Starting flows
18 Mar 18:56:27 - [info] Started flows
18 Mar 18:56:27 - [info] Server now running at

Already solved the problem myself.
Problem was in de nodejs version. I used the latest v13.11.0 which is not supported yet.
After removing this version and installing v10.19.0 my UI is working fine.
After that I also tried v12.16.1, which also works fine

Maybe this will be helpfull for any other beginner like me :wink:

1 Like

Well done for getting there before someone suggested that :slight_smile:
A good way to install (or update) node-red on Ubuntu is to use the recommended setup script which works for Raspbian and Ubuntu and other Debian based systems. That would have ensured you had a compatible nodejs version.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.