Node-red-dashboard upgrade - Lost my nodes

#1

I'm running Node-red on a Ubuntu laptop.

Upgrade toda to Node-red 0.19.5 and to Node-red-dashboard 2.12.2 -> result I lost my dashboards nodes so my /ui is completely unusable.

This is the message when I open Node-red
Flows stopped due to missing node types.

  • ui_base
  • ui_chart
  • ui_audio
  • ui_gauge
  • ui_switch
  • ui_numeric
  • ui_text
    And I have lost the structure of the UI in the dashboard tab.

I tried to disinstall Node-red-Dashoard and install previous version, but same result !

Any clue ?
tks
Marcello

0 Likes

#2

Hi

What steps did you take to upgrade?

Does the Node-RED log show any other errors relating to dashboard when it starts up?

Have you got any other dashboard-related modules installed such as node-red-contrib-mdashboard or node-red-contrib-ui?

0 Likes

#3

tks or the answer,

I have very few add on ... I have contrib_ui_list, that could be related.

First step I upgraded node-red-dashboard from the Palette and went up to 2.12.2. I had to restart Node-red and when I reopen the interface I got the error and all my nodes were gray-out.

At that point I upgraded the Node-Red to 0.19.5, but the situation didn't change.

At that point I tried to get back with previous version of Node-red-Dashboard, but the situation is the same.

I don't see a log file of Node-red. Where is it ?
tks
Marcello

0 Likes

#4

That will depend on how you are running Node-RED. If you are running on a Pi having used our update script, you ought to have a node-red-log command.

Otherwise, it will be wherever the output of node-red is being captured by whatever you are using to run node-red.

0 Likes

#5

I run on an Ubuntu Linux. In the .node-red directory I don't see any log file...

I reboot the Linux bos to restart Node-red ... Yes a bit brutal, but it is the only reliable option I found.

I have a recent backup of the Node-red configuration. Does it make sense to reinstall Node-red from scratch a reinstall the configuration ?

0 Likes

#6

No, you won't.
SSH into your installation and try typing node-red-log, and the log will be printed to your SSH client.

0 Likes

#7

But how do you run Node-RED? What do you do to get Node-RED started? Is it running a service? Do you manually run 'node-red' in a terminal?

0 Likes

#8

Yes Node-red in run as a service on the UBUNTU
and NO node-red-log is not installed. I believe is only installed on PI

0 Likes

#9

UPDATE

i tried to launch node-red knowing that it would have failed because the program was already running .... But i received some interesting info on the terminal:

10 Dec 21:56:37 - [warn] [node-red-dashboard/ui_audio] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mod e
10 Dec 21:56:37 - [warn] [node-red-dashboard/ui_base] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
10 Dec 21:56:37 - [warn] [node-red-dashboard/ui_button] SyntaxError: Block-scope d declarations (let, const, function, class) not yet supported outside strict mo de
10 Dec 21:56:37 - [warn] [node-red-dashboard/ui_chart] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mod e
10 Dec 21:56:37 - [warn] [node-red-dashboard/ui_colour_picker] SyntaxError: Bloc k-scoped declarations (let, const, function, class) not yet supported outside st rict mode

.... All errors related to the Dashboard nodes !!
Does it help?

0 Likes

#10

It would depend how you set it up to run as a service. If you had used the Pi install script, that works on Ubuntu, then you would have the node-red-log command.

So, if it is installed as a service, you can probably use:

sudo journalctl -f -u nodered -o cat

but you may need to change nodered for whatever you have the service named as.

Seeing your updated message with Block-scoped declarations messages... that means you are running too old a version of node.js. You should upgrade to Node 8.

0 Likes

#11

Node.js version v4.2.6

output from Journalctl

marcello@mqtt:~$ sudo journalctl -f -u node-red.service -o cat
file using your chosen key the next time you deploy a change.

10 Dec 19:08:32 - [info] Waiting for missing types to be registered:
10 Dec 19:08:32 - [info] - ui_base
10 Dec 19:08:32 - [info] - ui_chart
10 Dec 19:08:32 - [info] - ui_audio
10 Dec 19:08:32 - [info] - ui_gauge
10 Dec 19:08:32 - [info] - ui_switch
10 Dec 19:08:32 - [info] - ui_numeric
10 Dec 19:08:32 - [info] - ui_text

0 Likes

#12

Yup, 4.2.6 is too old. Node 4 is no longer maintained or receiving security fixes. You need to upgrade.

0 Likes

#13

remove the old-one first ??? sudo apt-get remove nodejs

and then install the new one : sudo apt-get -y install nodejs

Or could I leave the old one there ?

And why node.js has not been installed when I do the regular update of the Linux box ?

0 Likes

#14

It depends where you're getting node.js from. The version in the ubuntu repos is probably stuck back on that old version. You will need to add a more up to date source for it to get node 8 - https://github.com/nodesource/distributions/blob/master/README.md#deb

0 Likes

#15

Because the version of node.js installed with Ubuntu is old.
The easiest way of making sure you have a consistent set of tools on a Debian based system such as Ubuntu is to use the install/upgrade script for the Pi.
https://nodered.org/docs/hardware/raspberrypi

0 Likes

#16

Upgraded to 6.15.1!!

And voila ! Problem solved !!
So, I learnt that I have to keep node.js update manually

Many tks,
My Node-red is monitoring and managing my heating system ... Let me say that in this period is quite critical.

Tks a lot
Marcello

0 Likes

#17

You do realise that Node.js v6 is close to being at the end of support as well?

0 Likes

#18

Better plan for a V8 migration !

1 Like