Cannot use version 2.9.6 and above

#1

Hi,
Just curios to know why node-red won't start when installing versions newer than 2.9.5 of the node-red-dashboard, 2.9.5 works fine.
I guess either node-red or node.js or both have to be updated or?
The error turns out that the dashboard folder is removed and the nodes cannot be found. This is what the syslog says

Dec 21 19:57:14 raspberrypi Node-RED[3075]: 21 Dec 19:57:14 - [info]
Dec 21 19:57:14 raspberrypi Node-RED[3075]: Welcome to Node-RED
Dec 21 19:57:14 raspberrypi Node-RED[3075]: ===================
Dec 21 19:57:14 raspberrypi Node-RED[3075]: 21 Dec 19:57:14 - [info] Node-RED version: v0.16.2
Dec 21 19:57:14 raspberrypi Node-RED[3075]: 21 Dec 19:57:14 - [info] Node.js version: v4.2.1
Dec 21 19:57:14 raspberrypi Node-RED[3075]: 21 Dec 19:57:14 - [info] Linux 4.4.32-v7+ arm LE
Dec 21 19:57:15 raspberrypi Node-RED[3075]: 21 Dec 19:57:15 - [info] Loading palette nodes
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] ------------------------------------------------------
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_base] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_button] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_dropdown] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_switch] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_slider] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_numeric] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_text_input] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_colour_picker] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_form] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_text] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_gauge] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_chart] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_audio] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_toast] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_ui_control] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_template] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_link] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] [ui_date_picker] SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] ------------------------------------------------------
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] Missing node modules:
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [warn] - node-red-dashboard: ui_spacer
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [info] Removing modules from config
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [info] Settings file : /home/pi/.node-red/settings.js
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [info] User directory : /home/pi/.node-red
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
Dec 21 19:57:20 raspberrypi Node-RED[3075]: 21 Dec 19:57:20 - [info] Server now running at http://127.0.0.1:1880/
Dec 21 19:57:21 raspberrypi Node-RED[3075]: 21 Dec 19:57:21 - [info] Waiting for missing types to be registered:
Dec 21 19:57:21 raspberrypi Node-RED[3075]: 21 Dec 19:57:21 - [info] - ui_base
Dec 21 19:57:21 raspberrypi Node-RED[3075]: 21 Dec 19:57:21 - [info] - ui_switch
Dec 21 19:57:21 raspberrypi Node-RED[3075]: 21 Dec 19:57:21 - [info] - ui_chart
Dec 21 19:57:21 raspberrypi Node-RED[3075]: 21 Dec 19:57:21 - [info] - ui_gauge
Dec 21 19:57:21 raspberrypi Node-RED[3075]: 21 Dec 19:57:21 - [info] - ui_button
Dec 21 19:57:21 raspberrypi Node-RED[3075]: 21 Dec 19:57:21 - [info] - ui_text
Dec 21 19:58:02 raspberrypi systemd[1]: Stopping Node-RED graphical event wiring tool....
Dec 21 19:58:02 raspberrypi Node-RED[3075]: 21 Dec 19:58:02 - [info] Stopping flows

0 Likes

#2

The version of nodejs you have is well beyond end of life and is no longer supported. Newer versions of dashboard require a more recent nodejs.

0 Likes

#3

You are also using a very old version of Node-RED when you upgrade nodejs also spend the time to upgrade Node-RED

0 Likes