Ui_button missing after node-red-dashboard upgrade

After upgrading the node-red-dashboard palette from v 2.13.2 to v 2.19.3 ui_button type disappered from the palette and my flows having button element didn't start anymore.
The message error is the following:

Flows stopped due to missing node types.

  • ui_button


Node-red v. 0.19.5 running on docker.
I've already tried to restart the node-red docker - after upgrading the node-red-dashboard palette from within the Editor - but with no success.

Any thoughts?

Which version of node.js are you using ? Dashboard requires at least node v8, but even that is past end of life so 10 or 12 preferred. Core Node-RED is now at version 1.0.3 also...
If you need to stay where you are then you may need to revert by using npm i node-red-dashboard@2.13.2 or some lesser version that does work.

Tomorrow I'll check it and let you know. Thanks for your prompt support.

Here I am dceejay.
After running the Node-Rer docker and entering the docker (by using docker attach node-red command) I get the following error

Welcome to Node-RED

6 Feb 07:37:48 - [info] Node-RED version: v0.19.5
6 Feb 07:37:48 - [info] Node.js version: v6.16.0
6 Feb 07:37:48 - [info] Linux 4.15.0-39-generic x64 LE
6 Feb 07:37:48 - [info] Loading palette nodes
6 Feb 07:37:49 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
6 Feb 07:37:49 - [warn] rpi-gpio : Cannot find Pi RPi.GPIO python library
6 Feb 07:37:51 - [warn] ------------------------------------------------------
6 Feb 07:37:51 - [warn] [node-red-dashboard/ui_button] SyntaxError: Unexpected token ...
6 Feb 07:37:51 - [warn] ------------------------------------------------------
6 Feb 07:37:51 - [info] Settings file : /data/settings.js
6 Feb 07:37:51 - [info] Context store : 'default' [module=memory]
6 Feb 07:37:51 - [info] User directory : /data
6 Feb 07:37:51 - [warn] Projects disabled : editorTheme.projects.enabled=false
6 Feb 07:37:51 - [info] Flows file : /data/flows.json
6 Feb 07:37:51 - [info] Server now running at
6 Feb 07:37:51 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

6 Feb 07:37:51 - [info] Starting flows
6 Feb 07:37:51 - [info] Started flows
6 Feb 07:37:51 - [red] Uncaught Exception:
6 Feb 07:37:51 - TypeError: Cannot read property 'emit' of undefined
at /data/node_modules/node-red-dashboard/ui.js:406:11
at _combinedTickCallback (internal/process/next_tick.js:73:7)
at process._tickCallback (internal/process/next_tick.js:104:9)

npm ERR! Linux 4.15.0-39-generic
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "start" "--" "--userDir" "/data"
npm ERR! node v6.16.0
npm ERR! npm v3.10.10
npm ERR! node-red-docker@1.0.0 start: node $NODE_OPTIONS node_modules/node-red/red.js -v $FLOWS "--userDir" "/data"
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-red-docker@1.0.0 start script 'node $NODE_OPTIONS node_modules/node-red/red.js -v $FLOWS "--userDir" "/data"'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-red-docker package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node $NODE_OPTIONS node_modules/node-red/red.js -v $FLOWS "--userDir" "/data"
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs node-red-docker
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls node-red-docker
npm ERR! There is likely additional logging output above.
npm ERR! Linux 4.15.0-39-generic
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "start" "--" "--userDir" "/data"
npm ERR! node v6.16.0
npm ERR! npm v3.10.10
npm ERR! path npm-debug.log.896050243
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall open

npm ERR! Error: EACCES: permission denied, open 'npm-debug.log.896050243'
npm ERR! at Error (native)
npm ERR! { Error: EACCES: permission denied, open 'npm-debug.log.896050243'
npm ERR! at Error (native)
npm ERR! errno: -13,
npm ERR! code: 'EACCES',
npm ERR! syscall: 'open',
npm ERR! path: 'npm-debug.log.896050243' }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR! /usr/src/node-red/npm-debug.log

The node version provided with the docker image I use is node v6.16.0.

From the log it's clear that the dashboard module (after the upgrade to the last version from within the NOde-red IDE) didnt't load anymore. Is there a way to update the node-dashboard from within the node-red docker container? Do I have to launch the command you suggest me (npm i node-red-dashboard@2.13.2) when I'm attached to the node-red docker?

Otherwise I was thinking to to delete the node-red docker instance and create a new one (after backing-up flows, settings and credential files).. What do you think its the best option?

As long as you do the backup then yes I would start with another new docker container from https://hub.docker.com/r/nodered/node-red as that is up to date.

Solved by pulling the last Node-Red docker image and run a new container from that. This solved the dashboard problems.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.