Failed to load 'node-red-dashboard/ui_base Syntax error

For some reason I've had the following "Failed to load 'node-red-dashboard" error appear for two dashboard items, one for ui_switch and one for us_base and as a result I cannot seem to access the dashboard now

I was able to disable the ui_switch one via the palette, but I've been unable to disable the ui_base, it just does not change Any ideas ?

noderederror

Here's the view within the palette, where you can see their statuses

What version of node.js and node-red are you using?

Hi Nick, thanks for responding.

I’m running this in a Docker Container, ( looking in Portainer it’s [nodered/node-red-docker:latest] ). - Is there a way to tell ?

I've also just noticed that if I open a function to see the contents, do not make any changes - but at some point later hit deploy, I receive a message to say that those function were not properly configured
noderederror3

Its weird, the issue seems to be more prevalent on a windows machine via IE. Accessing and redeploying the function nodes via Safari on my iPad resolved the issue with them.

Very strange! And for some reason I can access the dashboard via Safari, but the dashboard option is missing on a Windows machine..

The dashboard also has changed its default colours - from the black/grey and green to white and light blue - see below..

Before

Now

I’ll keep an eye out, but somethings occurred and I’m not sure what..

Could that colour change be related to the ui_base error ?

The bottom is just the default light theme and the top the default dark theme. You should try Edge browser on windows as that has much better JavaScript support.

Doh ! Thanks @dceejay :blush:

Hello

I've installed node-red v0.20.5 and node.js v6.15.0 on an A13 olimex arm board, with OS Debian Wheezy 3.4.90+

I'm receiving same message

I've tryed installing both throug node-red UI and npm cli

:frowning:

@mauricio as of version 0.20.0 node.js is required to be at 8.x or 10.x

Hello, I've just installed node v6.15.0 because OS (armhf Wheezy) lacking some libraries

Hopefully soon I can try installing 10.x

Thanks

Hello

I've removed node.js and nodered

And reinstalled just downloading and unpacking https://nodejs.org/dist/v10.16.0/node-v10.16.0-linux-armv7l.tar.xz to /usr/local/lib/nodejs as https://github.com/nodejs/help/wiki/Installation states

then export PATH=/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/bin:$PATH

And sudo npm -i -g --unsafe-perm node-red

I can do node -v
v10.16.0

and npm -v
6.9.0

also, node-red
Welcome to Node-RED

12 Jun 12:54:06 - [info] Node-RED version: v0.20.5
12 Jun 12:54:06 - [info] Node.js version: v10.16.0
12 Jun 12:54:06 - [info] Linux 3.4.90+ arm LE
12 Jun 12:54:08 - [info] Loading palette nodes
12 Jun 12:54:15 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
12 Jun 12:54:16 - [warn] rpi-gpio : Cannot find Pi RPi.GPIO python library
12 Jun 12:54:16 - [info] Dashboard version 2.15.4 started at /ui
12 Jun 12:54:18 - [info] Settings file : /home/mauricio/.node-red/settings.js
12 Jun 12:54:18 - [info] Context store : 'default' [module=memory]
12 Jun 12:54:18 - [info] User directory : /home/mauricio/.node-red
12 Jun 12:54:18 - [warn] Projects disabled : editorTheme.projects.enabled=false
12 Jun 12:54:18 - [info] Flows file : /home/mauricio/.node-red/flows_puma.json
12 Jun 12:54:18 - [warn]

But still no dashboard, installing it with

sudo npm i -g node-red-dashboard

visit broker:1880 page, receiving same messages regarding

Failed to load 'node-red-dashboard/ui_base'
SyntaxError: Unexpected token )

Failed to load 'node-red-dashboard/ui_switch'
SyntaxError: Unexpected token )

??

Please any advice ?

Thanks

Hi, what browser are you using ?

I’ve noticed different experiences between the browsers ?

Maybe unrelated, but worth a look at loading Node Red in a few browsers.

Did you run
npm rebuild
as required after a change of nodejs version? I don't know if it will fix the problem you are seeing but it should be done anyway.
https://nodered.org/docs/getting-started/upgrading
If that doesn't fix it then uninstall node-red-dashboard and re-install it.

Hello, well a bit older one : Chrome Versión 47.0.2526.106

I have a Dell PC with ubuntu 14.04

Thanks

No I did not perform npm rebuild, either read that upgrading page, sorry me

I will and inform

Thanks

ok, I did

mauricio@puma:~/.node-red$ sudo npm cache clean --force
npm WARN using --force I sure hope you know what you are doing.

later

mauricio@puma:~/.node-red$ sudo npm install -g --unsafe-perm node-red

/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/bin/node-red -> /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/red.js
/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/bin/node-red-pi -> /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/bin/node-red-pi

bcrypt@3.0.5 install /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt
node-pre-gyp install --fallback-to-build

node-pre-gyp WARN Using request for node-pre-gyp https download
node-pre-gyp WARN Tried to download(404): https://github.com/kelektiv/node.bcrypt.js/releases/download/v3.0.5/bcrypt_lib-v3.0.5-node-v64-linux-arm-glibc.tar.gz
node-pre-gyp WARN Pre-built binaries not found for bcrypt@3.0.5 and node@10.16.0 (node-v64 ABI, glibc) (falling back to source compile with node-gyp)
make: Entering directory /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/build' CXX(target) Release/obj.target/bcrypt_lib/src/blowfish.o cc1plus: error: unrecognized command line option ‘-std=gnu++1y’ make: *** [Release/obj.target/bcrypt_lib/src/blowfish.o] Error 1 make: Leaving directory/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/build'
gyp ERR! build error
gyp ERR! stack Error: make failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:262:23)
gyp ERR! stack at ChildProcess.emit (events.js:198:13)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
gyp ERR! System Linux 3.4.90+
gyp ERR! command "/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/bin/node" "/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/lib/binding/bcrypt_lib.node" "--module_name=bcrypt_lib" "--module_path=/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/lib/binding" "--napi_version=4" "--node_abi_napi=napi" "--napi_build_version=0" "--node_napi_label=node-v64"
gyp ERR! cwd /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt
gyp ERR! node -v v10.16.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/bin/node /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/lib/binding/bcrypt_lib.node --module_name=bcrypt_lib --module_path=/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/lib/binding --napi_version=4 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v64' (1)
node-pre-gyp ERR! stack at ChildProcess. (/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack at ChildProcess.emit (events.js:198:13)
node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:982:16)
node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
node-pre-gyp ERR! System Linux 3.4.90+
node-pre-gyp ERR! command "/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/bin/node" "/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt
node-pre-gyp ERR! node -v v10.16.0
node-pre-gyp ERR! node-pre-gyp -v v0.12.0
node-pre-gyp ERR! not ok
Failed to execute '/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/bin/node /usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/lib/binding/bcrypt_lib.node --module_name=bcrypt_lib --module_path=/usr/local/lib/nodejs/node-v10.16.0-linux-armv7l/lib/node_modules/node-red/node_modules/bcrypt/lib/binding --napi_version=4 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v64' (1)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bcrypt@3.0.5 (node_modules/node-red/node_modules/bcrypt):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bcrypt@3.0.5 install: node-pre-gyp install --fallback-to-build
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

  • node-red@0.20.5
    updated 1 package in 170.503s

As you see, lot of errors, but broker:1880 page still works, and flows works, sadly I still receive the message regarding dashboard unexpected token

finally I uninstalled and reinstalled node-red-dashboard , error persists

Please note that I'm using precompiled for armv7l node-v10.16

Again thanks