Undefined dashboard

Currently, my Node Red had the following problem: when opening the dashboard, a tab with the name undefined is opened and thus the UI does not appear. Could anyone help? The panel is located on the IP

Info cmd:

Welcome to Node-RED

1 Nov 11:22:05 - [info] Node-RED version: v3.1.0
1 Nov 11:22:05 - [info] Node.js version: v18.17.1
1 Nov 11:22:05 - [info] Windows_NT 10.0.22621 x64 LE
1 Nov 11:22:05 - [info] Loading palette nodes
1 Nov 11:22:06 - [info] Dashboard version 3.6.1 started at /ui
1 Nov 11:22:06 - [warn] Missing node modules:
1 Nov 11:22:06 - [warn] - @studiobox/node-red-contrib-ui-widget-thermometer (0.7.7): ui_widget_thermometer
1 Nov 11:22:06 - [info] Removing modules from config
1 Nov 11:22:06 - [info] Settings file : C:\Users\Protec.node-red\settings.js
1 Nov 11:22:06 - [info] Context store : 'default' [module=memory]
1 Nov 11:22:06 - [info] User directory : \Users\Protec.node-red
1 Nov 11:22:06 - [warn] Projects disabled : editorTheme.projects.enabled=false
1 Nov 11:22:06 - [info] Flows file : \Users\Protec.node-red\flows.json
1 Nov 11:22:06 - [info] Creating new flow file
1 Nov 11:22:06 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

1 Nov 11:22:06 - [warn] Encrypted credentials not found
1 Nov 11:22:06 - [info] Server now running at
1 Nov 11:22:06 - [info] Starting flows
1 Nov 11:22:06 - [info] Started flows
1 Nov 11:34:15 - [info] Stopping flows
1 Nov 11:34:15 - [info] Stopped flows
1 Nov 11:34:15 - [info] Updated flows
1 Nov 11:34:15 - [info] Starting flows
1 Nov 11:34:15 - [info] Started flows

On assumption you are going to

Then the above error is your best clue as to why you get the error.
try re-installing node-red-contrib-ui-widget-thermometer

and see how you get on, I don't use DB - But plenty here who do

I have just noticed this line also.

1 Nov 11:22:06 - [info] Creating new flow file

it seems to me something has gone pop!
Have you made any changes lately?

And please tell me your Instance is not accessible on the interweb?

The missing node modules message, followed by Removing node from config is a warning that a node that is not used has been uninstalled manually using npm, and it has been removed from .config.nodes.json. As @marcus-j-davies says, the fact that it says creating new flows file may mean that you have started it a different way to the normal way you do it and it is looking in a different folder or for a different flows file.

1 Like

In fact, when I tried to install the thermometer pallet, it didn't show up in my flow for use. It only showed up if I accessed, but this was not my configured access (which I can no longer see the UI). What would be the procedure for adjustment? I'm a beginner in node-red. Thanks!

I saw a similar forum that said to uninstall pallete that was redundant like node-red-contrib-ui_j and node-red-dashboard, but both appear in use under "Manage pallete" even though it's not using contrib-ui_j. So, despite uninstalling via cmd, they keep popping up.

What do you mean by configured access. You need to give us more information.
How did you install it, how are you running it and what do you mean by configured access?

How should I adjust the .config.nodes.json file?

Don't touch it. It is maintained by node-red.

I am using a gateway device, my machine is configured with the ip mentioned at the beginning of 192, it is through this access that I view my construction, my configured panel, where I kept the work and viewed the dashboard. The thermometer pallete add even installed via cmd npm, did not appear in my access. After a while, the dashboard tab stopped working properly, opening only a tab with an undefined name. Given this, the thermometer could only be seen for use when I accessed the link starting with 127 through the browser (which I did not use).

You haven't answered that

Firstly, some terminology.
This is an example of the Node-red editor.
And this is an example of the Node-red dashboard.

  1. Do you see the editor at (or on your PC,
  2. Do you see the dashboard at (or on your PC,
  3. How do you start Node-red?
  4. What version of Node-red do you have? (Click the hamburger menu top right of the editor and it should be at the bottom of the drop-down menu)

I think you would be wise to uninstall node-red-contrib-ui_j because it was last updated 8 years ago and almost certainly does not work with the current version of Node-red.
If you can see the editor, you can select the hamburger menu at top right and Manage Palette to uninstall it.

ps please try to answer the questions!

I installed it via cmd, following the steps in the link: Running on Windows : Node-RED (nodered.org).
I run it through the browser, accessing

  3. I just access the link in answer 1, edit and view the dashboard in link 2.
  4. v.018.7

I had tried to uninstall via cmd, because in that place you talked about it appears that it is in use (even though it is not), so it does not show the option to uninstall. Would there be another way to uninstall? What line of code would you use for this? I also tried to update some pallets in this same tab, but it also gives an error.

The log you showed earlier show that you have version 3.1.0, which is the latest. How are you starting node-red to see 0.18.7?

What do you mean by gateway device? Is that the same device as the one you installed node-red on using the Running on Windows instructions?

Version 3.1.0 is accessed if you use In fact, it was there that the thermometer I was looking for appeared. But the panel I've always worked on was 1.
I'm referring to an IO-LINK system that is sending the data from the sensors I'm using to the red node. So, even if I go on to access which is working on the latest version, and it shows the thermometer I was looking for, it does not show the data transmitted from that system, because my machine (pc) is configured on ip Do you know which ip I could use on the machine for the data to be transmitted and displayed on that that is working?

You can see the list of nodes installed with node-red-contrib-ui-j at it's page on flows.nodered.org
It won't uninstall if you have any of these deployed.

OK, that explains it. You have two devices running node-red. The IO-LINK system ( which is running the ancient version 0.18.7 and the PC ( which you have installed version 3.1.0 on. is a special address that means 'the device the browser is running on` so when you use that in a browser on the PC it connects to the version of node-red running on the PC. When you use it connects to the IO-LINK system running node-red 0.18.7.

node-red-dashboard may not be compatible with the old version of node red, or with whatever version of nodejs is running on that device, which is why it does not work on the IO-LINK.

Are you able to update nodejs and node-red on the IO-LINK?

Right. But until this error of the undefined tab appeared, I used the node-red-dashboard in this old version that connects to my IO-LINK system.

In case, I believe, I would have to configure my IO-LINK system to this new ip of the latest version? If it wasn't possible, would there be a way to roll back the node red version to my previous one?

What did you do that stopped it working? Is the screenshot you showed above with the dashboard errors the node-red running on the IO_LINK device? If it used to be ok what did you do to make it fail?

I don't understand what you mean. I thought that node-red was running in the IO-link device. Please draw a diagram showing the various devices that we are talking about.

Again, which device are you talking about?

I installed node-red-contrib-ui-widget-thermometer. Thus, node-red updated to a newer version, changing the access link. The "link" to my system that is collecting the data to be viewed, was previously called as in the image.

If in the new tab with the recent version of node-red, what ip would I put in the URL in that module? And which ip should I put on my machine? Before the error was: url link in config (, my machine ( and access in browser by Since with the node red update this browser access changed to, what would be the ip's in the configuration link and on my machine? I think that amendment would do the trick, but I'm not sure.