Dashboard blank after upgrade

#1

My Dashboard is completely blank since my latest upgrade.
Running Dashboard 2.10.0, Node-Red 0.19.4, Node 8.12.0

Can´t find any error messages anywhere in Node-Red.

When loading the UI page in Chrome i get the following error:

"app.min.js:140 TypeError: io is not a function
at Object.connect (app.min.js:554)
at Object. (app.min.js:553)
at Object.invoke (app.min.js:63)
at R.instance (app.min.js:112)
at n (app.min.js:87)
at g (app.min.js:80)
at app.min.js:80
at app.min.js:42
at m.$eval (app.min.js:168)
at m.$apply (app.min.js:168)"

I have uninstalled and reinstalled the dashboard node.

Ny ideas?

Thanks

/Mats

0 Likes

#2

It's usually takes a couple hard reloads of the page to flush the browser cache.

0 Likes

#3

Tried that. Also tried different browsers on different devices. No luck so far...

0 Likes

#4

It can be difficult to clear cashing.
I've found the easiest way to 100% rule out caching is to load the site in chrome incognito mode...

0 Likes

#5

What did you upgrade and how?

0 Likes

#6

I´m on a RPi so I used the script that updates node-red and node. I think i needed to reinstall the dashboard node manually after that, but I am not sure. It was some time ago.
To try to remedy the problem I have since upgraded npm and then upgraded everything possible with "sudo apt-get upgrade". I have also uninstalled and reinstalled the dashboard node both through the palette manager and with npm.
I have uninstalled all other "extra" nodes that are not in use. I have removed all dashboard nodes in my flow and started over with a simple test.
I still get exactly the same problem all the time. Now I am running out of ideas other than reinstalling the complete rpi on a new memory card, which I would really like to avoid...

0 Likes

#7

In a terminal run node-red-log, then in another terminal restart node-red. Then try to open the ui in a browser. Post the messages from the log terminal here. Someone may see something relevant.

0 Likes

#8

Ok, here is the log from a fresh restart of node-red. Unfortunately nothing happens in the log window when I open the ui in a browser.

Starting Node-RED graphical event wiring tool...
Started Node-RED graphical event wiring tool.
30 Oct 21:39:04 - [info]
Welcome to Node-RED

30 Oct 21:39:04 - [info] Node-RED version: v0.19.4
30 Oct 21:39:04 - [info] Node.js version: v8.12.0
30 Oct 21:39:04 - [info] Linux 4.9.35-v7+ arm LE
30 Oct 21:39:05 - [info] Loading palette nodes
30 Oct 21:39:10 - [info] Dashboard version 2.10.0 started at /ui
30 Oct 21:39:11 - [info] Settings file : /home/pi/.node-red/settings.js
30 Oct 21:39:11 - [info] HTTP Static : /home/pi/bilder
30 Oct 21:39:11 - [info] Context store : 'default' [module=localfilesystem]
30 Oct 21:39:11 - [info] User directory : /home/pi/.node-red
30 Oct 21:39:11 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
30 Oct 21:39:11 - [info] Flows file : /home/pi/.node-red/flows_pitre.json
30 Oct 21:39:11 - [info] Server now running at http://127.0.0.1:1880/
30 Oct 21:39:11 - [warn]

Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

30 Oct 21:39:11 - [info] Starting flows
30 Oct 21:39:12 - [info] Started flows

0 Likes

#9

That all looks ok, but you are still getting the error in the browser. I presume there is nothing in the log when you open the browser.
In your situation I can't think of anything else to do other than completely uninstall node-red and reinstall it. I am not sure of the easiest way to do that though. Hopefully someone will chip in and tell us. I couldn't see it in the docs.

0 Likes

#10

What nodes do you have installed? If you go to .node-red/node_modules (cd .node-red/node_modules) and type ls node-red* what shows up?

Can you also supply your flow file? You will need to back up a level (cd ..) and enter cat flows_pitre.json tehn copy it and past it to a reply making sure to add three backtic's on the line before you past in the flow and the line after the flow.

0 Likes