Dashboard tabs not appearing on UI

Apologies for the repost- I had to redact some info from screenshots on the original post.

Anyway - I've got a node red installation on a centos 8.5.2111 server which has been working fine gathering data from several remote raspberry pi's for a while now. I've come to expand the dashboard with more tabs but I can't work out why they're not appearing on the UI. I know there should be a hamburger menu in the top left - it appears on the dashboard of the individual Pi's, but not on the server.

The dashboard:

The editor:

From the startup of nodered:
16 Dec 06:11:15 - [info] Node-RED version: v2.1.4
16 Dec 06:11:15 - [info] Node.js version: v12.22.7
16 Dec 06:11:15 - [info] Linux 4.18.0-348.2.1.el8_5.x86_64 x64 LE
16 Dec 06:11:16 - [info] Dashboard version 3.1.2 started at /ui

Any thoughts on making this work? If i've gone wrong somewhere I can't see the forest for the trees.

Try clearing the cache in the browser, via its menus. If that doesn't work then try a different browser.

Have you customised the header?
I would expect the dashboard title to be Main not HDF

I've tried 2 browsers, firefox and chrome. I use firefox mostly but have chrome for testing and I get the same result on both.

@jbudd : I've not knowingly customised the header, I can change that title here:

Also of note i've set it to always show the side menu but still nothing appears.


Are there any dashboard widgets enabled in Alarms:Group1 ?

That was it... feeling a bit daft now. I was expecting the tab to appear in the list but just be blank.

I added some more widgets to test and the tabs appeared. I had a notification widget on that tab but of course there was nothing to see on the page itself.

Okay thanks!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.