Dashboard UI shows blank screen

Sorry, I dont understand: what or where is site tab, and I am not sure what you mean by " drag the test test above the Home tab and deploy" I have deployed the flow if that is what you mean.

drag the tab to rearrange the tabs
Screen Shot 2019-12-12 at 3.55.24 PM Screen Shot 2019-12-12 at 3.39.02 PM

this is the Site tab

1 Like
  1. Rearraged tab & deployed:

  2. Site tab

  3. I am not sure if this helps, on the UI page, inspect element shows some errors, I am no html expert so do not know what it means:

I feel we are getting closer, eliminating each variable.


First can you are you running stretch gui or stretch lite?
can you open a terminal and enter

cd $HOME/.node-red/node_modules
ls node-red*
ls node-red* -d

and paste the results here.

Also can you try this, start NR from the command line using
node-red testing.json
this will open a new empty flow. Then just copy in the flow I provided and test it.

Have you got anything else on this Pi other than NR. There must be something causing a conflict and it could be one ot the other nodes you have ins

  1. Stretch gui
    2.ls node-red*
    pi@raspberrypi:~/.node-red/node_modules $ ls node-red*
    advanced-ping LICENSE package.json README.md

icons index.js package.json screenshot2.png screenshot_input.png
index.html node_modules README.md screenshot3.png setup.xml

api icons index.js node_modules README.md
docs index.html LICENSE package.json

arp LICENSE.txt package.json README.md

broadlinkDB broadlink.jpg examples LICENSE nodes package.json README.md

application CLA.md examples LICENSE package.json README.md

LICENSE node_modules nodes package.json README.md

ip.html ip.js LICENSE package.json README.md

icons LICENSE oled.html oled.js package.json README.md

examples locales package.json play-audio.js
LICENSE node-red-contrib-play-audio-2.3.1.tgz play-audio.html README.md

icons LICENSE package.json README.md sensor.html sensor.js

icons Makefile package.json README.md webhookrelay.html webhookrelay.js

CHANGELOG.md examples package.json worldmap worldmap.js
emojilist.md LICENSE README.md worldmap.html

Charts.md fixfa.js LICENSE package.json
config-fields.md gulpfile.old license.js README.md
CONTRIBUTING.md index.js node_modules ui.js

35-arduino.html 35-arduino.js LICENSE locales package.json README.md

55-dweetio.html 55-dweetio.js LICENSE package.json README.md

36-rpi-gpio.html LICENSE nrgpio package.json testgpio.py
36-rpi-gpio.js locales nrgpio.py README.md

88-ping.html 88-ping.js LICENSE locales package.json README.md

57-pushbullet.html 57-pushbullet.js icons LICENSE package.json README.md

LICENSE package.json random.html random.js README.md

25-serial.html LICENSE node_modules README.md
25-serial.js locales package.json

17-smooth.html 17-smooth.js icons LICENSE package.json README.md

icons LICENSE package.json WeMoNG.html
lib node_modules README.md WeMoNG.js
pi@raspberrypi:~/.node-red/node_modules $

3.ls node-red* -d
pi@raspberrypi:~/.node-red/node_modules ls node-red* -d node-red-contrib-advanced-ping node-red-contrib-web-worldmap node-red-contrib-alexa-local node-red-dashboard node-red-contrib-amazon-echo node-red-node-arduino node-red-contrib-arp node-red-node-dweetio node-red-contrib-broadlink-control node-red-node-pi-gpio node-red-contrib-ibm-watson-iot node-red-node-ping node-red-contrib-ifttt node-red-node-pushbullet node-red-contrib-ip node-red-node-random node-red-contrib-oled node-red-node-serialport node-red-contrib-play-audio node-red-node-smooth node-red-contrib-sensor-ds18b20 node-red-node-wemo node-red-contrib-webhookrelay pi@raspberrypi:~/.node-red/node_modules

I have also sudo update and upgraded pi

I will try the empty flow next, good idea, I presume I have to stop NR first then node-red testing.json.

Just tried that, still the same! Maybe it is the pi. but everything works, it just not serving the UI page correctly (port clashes?)

Well I just flashed an SD card with stretch GUI, installed NR installed all your extra nodes and tested. The button shows fine, so now I go back to a previous question, what other things do you have installed on this machine? Better yet, since it is a experimental machine, why not flash the SD card with the latest version of buster, reinstall NR and see if it works.

1 Like

@zenofmud, I really appreciate your time and effort for this. I use the pi mainly for NR development and learning. The are no other things I installed specifically apart from what came out of the box (I install via Noobs). The only other thing is I run the pi out of a USB stick instead of sd card.
I will check all config first with other pi before reflashing, in the mean time I wonder what the error code on the UI page means.

I know you have restarted repeatedly, but have you flushed the browser cache on the machine that is used to browse the dashboard ?

@dceejay yes, I have tried clearing cache and also tried in incognito and private mode both in firefox and chrome on the mc that is used to browse the dashboard. It is starting to look like might be outside NR. However everything works, all other flows ok, mqtt, I can acces NR on ip:1880, ssh to the pi, etc. It just simply not serving the dashboard UI interface page correctly (browser recognise and accept the url but just display a blank page).


Hi, I have problem with dashboard ui.
I am able to receive data from IBM IoT and see them in debug messages. However, the ui dashboard does not show anything. Would you tell me what I am missing here? Thanks!