In the Running on Raspberry Pi : Node-RED page it says the minimum version of Raspbian is jessie. This is incorrect. I tried to upgrade yesterday and ran into this big problem (a non-functioning Node-RED):
This can take 20-30 minutes on the slower Pi versions - please wait. Stop Node-RED ✔ Remove old version of Node-RED ✔ Remove old version of Node.js ✔ v6 Update Node.js LTS ✘ Failed to install Node.js - Exit Clean npm cache Install Node-RED core Move global nodes to local Install extra Pi nodes Npm rebuild existing nodes Add shortcut commands Update systemd script Error: nodejs : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u2 is to be installed
I am no linux expert, but after a very long frustrating battle I managed to install Node.js v10 manually (example from: GitHub - nodesource/distributions: NodeSource Node.js Binary Distributions):
curl -sL https://deb.nodesource.com/setup_10.x -o nodesource_setup.sh sudo bash nodesource_setup.sh sudo apt-get install nodejs sudo apt-get install build-essential
And then I edited the above update-script in such a way that the Node.js part is skipped. Finally it was able to install the latest version of Node-RED v1.2.9
I know there is an existing topic about this (Raspian Jessie not supported with latest bash script), but it is already closed, and mentions a solution of upgrading to stretch or buster, but that is really a solution for everybody, and would mean that jessie is not supported anymore.
I suggest either to remove the mentioning of support for Jessie, or change the update-script so that it recognizes this situation and uses Node.js v10 instead of v12.
Please let me know your thoughts on this proposal.