Debug-problem-with-press

#1

hello I have a problem at debug button I press the debug button and the message doesn’t work .

0 Likes

#2

Hi,

I’m sorry, but there’s not enough information there to understand what you mean. What debug button?

Do you have an example flow you can share to show what you mean? Or a screenshot?

0 Likes

#3

Hi ,
I'm having same problem I'm a beginner and I started by IBM recipes:


and in the step that I should receive message in the debug nothing appears
So any idea what should i do ?

0 Likes

#5

0 Likes

#6

You need to configure the node as in the instructions you are following which is in section 6.7

0 Likes

#7

Hi,
Thank you for your reply
Well I did all the steps in the tutorial
I just took snapshot to that node

0 Likes

#8

It stats that I should wait till a new message is received …
But what message will be received …should I run my sigfox in arduino web editor…so that it can send and receive message then wait maybe a message will appear in the debug tab in Node-Red…
Well I tried that already but it didn’t work…
So how can i make message start to flow from my sigfox MGRFOX1200 to be displayed in the debug tab
Thanks in advance

0 Likes

#9

Your image shows
Authentication : API Key

The instructions show
Authentication : Bluemix Service

The text says “Drag in an ibmiot node and double-click it to open its properties.
Change Authentication to Bluemix Service, and add AuthDevice to the Device Id as this is the device that will forward the data from the Sigfox backend and thereby send data from all the devices of the Sigfox Device Type as defined previously:”

0 Likes

#10

Well I'm so grateful that you are trying to help :slight_smile:
The problem is that the reciepe was made with an older GUI so now the tab just has 2 options either quick start or API Key as shown in the image and the IBMiot wasn't connected until I wrote the API key and token..

0 Likes

#11

Where are you running Node-RED? If you’re running within IBM Cloud the Bluemix Service option would be available if you had created an instance of the IoT Platform and bound it to your Node-RED application. If you haven’t done that, then entering your API Key manually should be sufficient. As you say, the node shows it’s connected.

Have you looked at your IoT Platform service instance to see if your devices are connected and sending data?

I should also add, you’ve taken over the topic that @chrisious started - we don’t know what their issue actually was. @chrisious if you can share any more details, you may be better to start a new topic with those full details as @Hala has kinda taken over here.

0 Likes

#12

Well thanks alot for ur reply
I created the Node-Red in bluemix service and after your post I bound it to an instance of IoT platform
So the Bluemix option has appeared and i chose it instead of the API
In the IoT Platform service instance : here are the devices that I created and as shown SigfoxGW is running.


Now still i have no messages displayed in the debug tab in the Node-Red nor in SigFox backend..

0 Likes