Disable NR's websocket for session

#1

I can access my home Node Red from work, and successfully deploy. However, it constantly shows "Lost connection to server, reconnecting...". I'm assuming this means the websocket connection is failing, presumably because of the corporate firewall / proxy.

Since this is not something I can control, is it possible to "turn off" the websocket capability while browsing from work, so it doesn't constantly try, and obscure the screen with the notification? I'm guessing the only impact would be to the update of status on nodes and debug messages (so this tab would probably need to be disabled too).

0 Likes

#2

If you are talking about accessing the Node-RED admin interface then no. It is fundamental to the operation of the UI AFAIK.

Personally, I can't see that this would be a useful use of scarce development resources when so many other things are already in-flight.

It would be much better to set up a secure tunnel or VPN to your home network anyway so that you are not exposing Node-RED to the Internet - bearing in mind that Node-RED hasn't been fully security vetted - indeed, I'm not sure whether anyone has even run a comprehensive penetration test on it?

0 Likes

#3

Well it was worth a try. I run multiple instances of Node Red, only one of which is in a DMZ and publicly accessible and contains nothing “dangerous". If somebody hacks into it and guesses properly constructed MQTT messages to the rest of the my system, good luck to them.

0 Likes