Disabled flow: how to "disable" also nodes within it


Hi guys,
i have a local nodered instance used to test some nodes / flows before to move to the final hw. After the release, i usually keep those flows - disabled.
But I see that the nodes within those flows are still running, filling with errors the debug section. Am i missing something? Is there a way to disable all (flow and its nodes)?



hi i´m grat new in Node-RED,
For me they looks disabled, as example Incoming TCP are disconnected,
i cant inject something...
How ever, if i have an test with error in it, they will be debug every deploy.



Can you generate a simple test flow showing the problem? That is a flow that when disabled continues to generate errors?

1 Like


Hi @Colin, sure!
This is a flow in which i'm using the S7 node; even if it's disabled, it raises errors on failed connection:

[{"id":"2655ee88.bb2902","type":"s7 in","z":"24b54f70.115b4","endpoint":"bd348486.ac7d18","mode":"single","variable":"Analogico1","diff":true,"name":"LOGO8_v2","x":210,"y":140,"wires":[["1b290e34.783432","ad19cd21.1d4c8"]]},{"id":"1b290e34.783432","type":"debug","z":"24b54f70.115b4","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"payload","x":390,"y":120,"wires":[]},{"id":"ad19cd21.1d4c8","type":"ui_gauge","z":"24b54f70.115b4","name":"","group":"8389b2aa.13894","order":1,"width":0,"height":0,"gtype":"gage","title":"Voltage","label":"Volt","format":"{{value}}","min":0,"max":"1000","colors":["#00b500","#e6e600","#ca3838"],"seg1":"","seg2":"","x":380,"y":160,"wires":[]},{"id":"5943fa9b.6bcf34","type":"comment","z":"24b54f70.115b4","name":"ANALOG SIGNAL FROM SIEMENS PLC","info":"","x":300,"y":80,"wires":[]},{"id":"bd348486.ac7d18","type":"s7 endpoint","z":"","address":"","port":"102","rack":"0","slot":"2","localtsaphi":"01","localtsaplo":"00","remotetsaphi":"02","remotetsaplo":"00","connmode":"tsap","cycletime":"500","timeout":"1500","verbose":"default","name":"LOGO8_v2","vartable":[{"addr":"DB1,INT50","name":"Analogico1"}]},{"id":"8389b2aa.13894","type":"ui_group","z":"","name":"Default","tab":"b932765f.788718","disp":true,"width":"12","collapse":true},{"id":"b932765f.788718","type":"ui_tab","z":"","name":"first","icon":"dashboard","disabled":false,"hidden":false}]


But i remember it was quite the same with the Serial node.
Thanks for suggesting!



What node is the S7 node? node-red-contrib-something probably. I guess that it probably has a config node behind it for setting up the connection. That may be the issue. Are you sure you only use that config node on one flow?
It may be that config nodes are not automatically disabled when flows with nodes using them are disabled, I don't know. Perhaps @dceejay could comment.



Hi @Colin, yes sorry, it's the node-red-contrib-s7.
In the flow I use only that node. And if I double-click on the node in the error, it opens that node...



By default, config nodes are global - they are not tied to any one flow. Disabling a flow will not disable the config node. It is then down to how the config node has been implemented as to what it does. Some config nodes won't do anything if there are no active flow nodes using them - such as the MQTT Broker node. Some config nodes may try to do something such as establish a connection regardless of whether there are any flow nodes. I don't know the S7 node in particular, but that would explain this behaviour.

You can change the scope of a config node so that it is tied to a particular flow - and will then get disabled with the flow. In its edit dialog there is a drop-down in the footer to set its scope - change that to the flow you want it to be tied to. Note that when you do that, it will only be available for use by nodes on that flow.

1 Like


hi @knolleary

you saved the day! Changing the scope does exactly what i was looking for!
Thanks a lot :slight_smile: