Discord node bot mentions not working

This is probably the wrong place for this question, but since discord support won't help with this and I'm trying to use the discord node to send myself messages, I thougt I'd start here before asking elsewhere.

I set up node-red-node-discord earlier this week, which says you can include mentions in its doc, but those mentions stopped working, i.e. the messages including mentions no longer get highlighted in discord and the iOS Discord app badge no longer increments the unread messages count.

I think that this stopped working when, while trying to tweak my notification settings, I reset the notifications override in the app. I tried re-authorizing the bot, kicking it off and reinviting, restarting my iPhone, restarting the app, and a half dozen other things including setting the notification settings the way I think they should enable the bot mentions (every message for the server, the bot, and the channel).

Has anyone faced this issue and figured out how to fix it? It seems like I'm just going to have to switch to another messaging app, like telegram or something.

First you'll want to clarify which Discord nodes you are using, as there are multiple? It would also be useful to have some information regarding your Node-RED setup?

I'm using the send message node. The messages send. I get them. It's just that the mentions aren't working. They were working at least through 1:31pm yesterday:

See how the 1:31 message highlights the mention of @hepcat72, but the 8:01pm one doesn't?

So that particular node hasn't been updated in over 2 years. I use node-red-contrib-discord-advanced which depends on a more up-to-date version of discord.js (It does however require >= node v16.6.0). Would you be open to switching nodes to resolve the issue?

Alternatively, there is also node-red-contrib-discordjs which I used prior to the above (still use it on one device) that is in between the versions used in node-red-node-discord-node-red-contrib-discord-advanced? (the node you're using is the oldest of the three)

If you can't switch for some reason, could you provide an example of the data being received by the discord node (Use a debug node set to output the complete msg object).

Actually, it is now working. Something I enabled in the bot's permissions last night made it start being able to @mention users. I'd noted that using @here and @everyone worked. It was just that @hepcat72 was not working. I also noted that I could @mention myself manually.

There's no obvious permission setting change that I can attribute it to. I enabled a bunch of permissions and re-invited the bot, hoping that something would fix it... and it did. I'm not sure if this is completely a problem of the bot or the node, but regardless, I just won't mess with it anymore.