Docker gives Error: EACCES: permission denied, copyfile -> ‘/data/settings.js’

Dear community members,

I tried to deploy node-red on Azure IoT edge device using nodred lates image, though I receive the following error:

Error: EACCES: permission denied, copyfile '/usr/src/node-red/node_modules/node-red/settings.js' -> '/data/settings.js'
    at Object.copyFileSync (node:fs:2817:3)
    at copyFile (/usr/src/node-red/node_modules/fs-extra/lib/copy/copy-sync.js:73:6)
    at onFile (/usr/src/node-red/node_modules/fs-extra/lib/copy/copy-sync.js:59:25)
    at getStats (/usr/src/node-red/node_modules/fs-extra/lib/copy/copy-sync.js:51:44)
    at handleFilterAndCopy (/usr/src/node-red/node_modules/fs-extra/lib/copy/copy-sync.js:36:10)
    at Object.copySync (/usr/src/node-red/node_modules/fs-extra/lib/copy/copy-sync.js:29:10)
    at Object.<anonymous> (/usr/src/node-red/node_modules/node-red/red.js:129:20)
    at Module._compile (node:internal/modules/cjs/loader:1105:14)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1159:10)
    at Module.load (node:internal/modules/cjs/loader:981:32) {
  errno: -13,
  syscall: 'copyfile',
  code: 'EACCES',
  path: '/usr/src/node-red/node_modules/node-red/settings.js',
  dest: '/data/settings.js'

I am using Raspberry Pi 3 Model B Raspbian GNU/Linux
I also tried to follow this tutroial
For setting the container create options for the IoT edge device on Azure IoT hub I provide the following:

    "HostConfig": {
        "Privileged": true,
        "Binds": [
        "PortBindings": {
            "1880/tcp": [
                    "HostPort": "1880"

Other modules of IoT edge device are running, but node-red...

Cross posted and answered in Stack Overflow