ERESOLVE error when trying to remove a contrib node

This isn't helping. You appear to have installed 2 nodes that are trying to claim the node hysteresis.

Odd that it can't find kodi.js. I have to say that with all the filing system issues you are having, it makes me doubt the validity of your filing system. Have you run a check on it?

Which nodes are missing?

Thanks for your help.

Eventually... I've installed all the missing nodes using Palette Manager and deleted nodes from the flow that I could determine what they were. I thought I had manually installed all the nodes this morning - but I suspect some of the names didn't agree (in some way).

At least now I can start NR and not get a message with a long string of missing nodes.

1 Like

Got there at long-last. Phew - what a journey!!!
It's a relief to get it working again as this particular Pi was running my Home Automation - home lighting, security lights, IR detectors, Owntracks mobile phone tracker as well as some MySQL databases.

Starting as a systemd service.
24 Jan 15:24:28 - [info]
Welcome to Node-RED

24 Jan 15:24:28 - [info] Node-RED version: v3.0.2
24 Jan 15:24:28 - [info] Node.js version: v16.19.0
24 Jan 15:24:28 - [info] Linux 5.10.52-v7l+ arm LE
24 Jan 15:24:30 - [info] Loading palette nodes
24 Jan 15:24:36 - [info] Worldmap version 2.33.0
24 Jan 15:24:36 - [info] Dashboard version 3.3.1 started at /ui
24 Jan 15:24:36 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
24 Jan 15:24:37 - [info] Settings file : /home/pi/.node-red/settings.js
24 Jan 15:24:37 - [info] Context store : 'default' [module=memory]
24 Jan 15:24:37 - [info] User directory : /home/pi/.node-red
24 Jan 15:24:37 - [info] Projects directory: /home/pi/.node-red/projects
24 Jan 15:24:37 - [info] Server now running at http://127.0.0.1:1880/
24 Jan 15:24:37 - [info] Active project : home_automation
24 Jan 15:24:37 - [info] Flows file : /home/pi/.node-red/projects/home_automation/flows_iot-super-server.json
24 Jan 15:24:37 - [warn] Using unencrypted credentials
24 Jan 15:24:38 - [info] Starting flows
24 Jan 15:24:38 - [info] Started flows

One of the reasons I don't bother or want a DB on my home automation setup, harder to constantly back-up. InfluxDB doesn't count because if I lost the data, frankly, I couldn't care less.

Something you might consider. An up-to-date SD-Card with a copy of your setup so that, in an emergency, you could simply switch to it. That way you could take your time recovering the full setup.

Thanks - Great idea. I'll have to implement that.