Start node red without loading any flows

My node-red has suddenly stopped working with the following errors (looping) when i do a node-red-start from a SSH terminal:

[info] [tuya-smart-device:Dinning room] findDevice(): Initiating the find command
[info] [tuya-smart-device:Dinning room] findDevice(): Cannot find the device, re-trying...

the :1880 doesnt load saying that the page is not working...
Is the a way to start node red without loading any flows so I can then try elimination on each flow.

node-red --safe should do that.

Any deploy will then start the flows.

Finally got node-red going again but when I try and install any new nodes from manage pallette it just keeps trying to load and in the end I have to close it which then locks up node-red meaning I have to do a reboot. The error log gives the following which is beyond me trying to fix it:

2024-04-11T09:01:18.982Z Install : node-red-contrib-tapo-new-api 0.5.3
2024-04-11T09:01:19.214Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-contrib-tapo-new-api@0.5.3
2024-04-11T09:01:22.722Z [err] npm
2024-04-11T09:01:22.724Z [err]
2024-04-11T09:01:22.724Z [err] WARN config production Use `--omit=dev` instead.
2024-04-11T09:01:28.505Z [err] npm
2024-04-11T09:01:28.506Z [err]
2024-04-11T09:01:28.506Z [err] WARN
2024-04-11T09:01:28.506Z [err]
2024-04-11T09:01:28.507Z [err] old lockfile
2024-04-11T09:01:28.507Z [err] npm
2024-04-11T09:01:28.507Z [err] WARN old lockfile The package-lock.json file was created with an old version of npm,
2024-04-11T09:01:28.508Z [err] npm WARN
2024-04-11T09:01:28.509Z [err] old lockfile so supplemental metadata must be fetched from the registry.
2024-04-11T09:01:28.509Z [err] npm
2024-04-11T09:01:28.509Z [err] WARN old lockfile
2024-04-11T09:01:28.509Z [err] npm WARN old lockfile This is a one-time fix-up, please be patient...
2024-04-11T09:01:28.510Z [err] npm WARN old lockfile

Can anyone offer any help to fix this. Regards Don....

Delete the package-lock file in your node red usedir, probably ~/.node-red

Hi Colin, Thanks for your help. Can I confirm that I delete the package-lock.json file ??

Yes. Any time you are worried about deleting a file then rename it initially (or move it away), then if you have a problem you can always put it back.

I can see that you have a large number of modules installed, how long did you wait after

before giving up. If you are on a low powered pi this could take many minutes.

1 Like

After 30 mins it was still whirling so I closed it and that is when it locks nodered and I have to re-boot.

Hi Colin, that fixed it!!...many thanks for your help.

Spoke to soon, tried to load smartnora from the palette menu which failed with the following error:

2024-04-13T10:49:20.714Z Install : node-red-contrib-smartnora 1.22.1
2024-04-13T10:49:20.903Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-contrib-smartnora@1.22.1
2024-04-13T10:49:23.819Z [err] npm
2024-04-13T10:49:23.821Z [err]
2024-04-13T10:49:23.821Z [err] WARN config production Use `--omit=dev` instead.
2024-04-13T10:49:40.654Z rc=null

How do I exactly use --omit=dev which implies the solution ??

You can ignore that warning

Hi Colin, any idea on how to fix this so that I can udate the smartnora app ??
Regards Don...

Did it hang again at that point? If so I suspect you may have a problem with your system. Is it an SD card?

Hi Colin, No, it didnt hang, just said failed to load and check logs. Others load and update OK from the palette, just a problem with smartnora so far??

Please, in a command window, go to your .node-red folder (/home/pi/.node-red) and run

npm remove node-red-contrib-smartnora
npm install node-red-contrib-smartnora

And copy/paste the full output here.

Hi Colin, I have done as you suggested and this is the outputs from both remove and install....

pi@raspberrypi:~/.node-red $ npm remove node-red-contrib-smartnora

removed 76 packages, and audited 659 packages in 24s
95 packages are looking for funding
run npm fund for details
35 vulnerabilities (2 low, 11 moderate, 14 high, 8 critical)
To address issues that do not require attention, run:
npm audit fix
To address all issues possible (including breaking changes), run:
npm audit fix --force
Some issues need review, and may require choosing
a different dependency.
Run npm audit for details.

pi@raspberrypi:~/.node-red $ npm install node-red-contrib-smartnora
Killedâ ‚â ‚â ‚â ‚â ‚â ‚â ‚â ‚â ‚â ‚â ‚â ‚â ‚) â § idealTree:.node-red: sill idealTree buildDeps
pi@raspberrypi:~/.node-red $

Did you break into it?

Hi Colin,
Not sure what you mean. The nora nodes have been removed from the flows but not reinstalled ??

It said Killed. Did it just say that or did it do it by itself?

Hi Colin, I just ran the 'npm install node-red-contrib-smartnora' command as you suggested and that was what come back (very quickly)

I suggest that you get a new, good quality, SD card from a reputable source (if you have not got one) and rebuild your system. As I suggested earlier, I think the card may be dying.