Error Cannot GET /homeassistant/entities

#1

Just installed Node-RED and every thing went well, I thought. Logged in and can see everything even the Home Assistant in the left menu. On my first flow I entered the "Current State Flow" from the left menu and dragged that component into the flow layout. I then doubled clicked on that item to set it up and received the error: Error Cannot GET /homeassistant/entities. Stuck here.

#2

Here is my Log File

[Log
[INFO] Disabling SSL
[INFO] Updating IDE Users
[INFO] Adding IDE User mickiepitts
[INFO] Updating HTTP Node User
[INFO] Adding HTTP Node User mickiepitts
[INFO] Enabling Projects
[INFO] Attempting to install/update nodes: node-red-contrib-home-assistant
npm info it worked if it ends with ok
npm info using npm@5.0.3
npm info using node@v8.1.3
npm http fetch GET 200 https://registry.npmjs.org/node-red-contrib-home-assistant 544ms
npm http fetch GET 200 https://registry.npmjs.org/node-red-contrib-home-assistant/-/node-red-contrib-home-assistant-0.3.2.tgz 347ms
npm info lifecycle node-red-contrib-home-assistant@0.3.2~preuninstall: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~uninstall: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~postuninstall: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~preinstall: node-red-contrib-home-assistant@0.3.2
npm info linkStuff node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~install: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~postinstall: node-red-contrib-home-assistant@0.3.2
npm info lifecycle undefined~preshrinkwrap: undefined
npm info lifecycle undefined~shrinkwrap: undefined
npm info lifecycle undefined~postshrinkwrap: undefined
npm info ok
npm info it worked if it ends with ok
npm info using npm@5.0.3
npm info using node@v8.1.3
npm info lifecycle node-red-docker@1.0.0~prestart: node-red-docker@1.0.0
npm info lifecycle node-red-docker@1.0.0~start: node-red-docker@1.0.0

node-red-docker@1.0.0 start /usr/src/node-red
node $NODE_OPTIONS node_modules/node-red/red.js -v $FLOWS "--userDir" "/share/node-red"
12 Dec 09:01:29 - [info]
Welcome to Node-RED
===================
12 Dec 09:01:29 - [info] Node-RED version: v0.19.5
12 Dec 09:01:29 - [info] Node.js version: v8.1.3
12 Dec 09:01:29 - [info] Linux 4.14.81-v7 arm LE
12 Dec 09:01:30 - [info] Loading palette nodes
12 Dec 09:01:34 - [info] Settings file : /share/node-red/settings.js
12 Dec 09:01:34 - [info] Context store : 'default' [module=memory]
12 Dec 09:01:34 - [info] User directory : /share/node-red
12 Dec 09:01:34 - [warn] No active project : using default flows file
12 Dec 09:01:34 - [info] Flows file : /share/node-red/flows.json
12 Dec 09:01:34 - [info] Creating new flow file
12 Dec 09:01:34 - [warn]


Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

12 Dec 09:01:34 - [info] Starting flows
12 Dec 09:01:34 - [info] Started flows
12 Dec 09:01:34 - [info] Server now running at http://127.0.0.1:1880/](http://)

#3

my guess would be that docker is bloacking access to the ports that home assistant uses.
FYI If using docker it would be useful to state that