Error: Hostname/IP doesn't match certificate's altnames

Recently I started getting the below from an external endpoint.

"Error: Hostname/IP doesn't match certificate's altnames: "Host: is not in the cert's altnames:, DNS:*""

I presume it most likely they've done something dumb at their end, however in any case for the moment my intent is assume they'll eventually fix it ans to set node-red to ignore the errors and process anyway.

But, how?
I've tried
and then
pm2 stop node-red
pm2 start node-red

to no avail. Ideas?

(I saw an earlier post on here with similar issue but no outcome)

Assuming this is caused by using an http request node, you can set rejectUnauthorized to false to ignore certificate errors, although this is not recommended, unless tplink is actually changing to rbictg.

In these cases, you should always check the certificate details. It could indicate that something has intercepted your link and substituted the cert.

This can happen if you are on a corporate network and the organisation is monitoring connections. But, of course, there are also more nefarious reasons too.

Thanks, rejectUnauthorized false in the previous node solved that issue, however I no longer trust those devices (and it now returns a 503) so I'll replace them with another type.

I feel like kasa have likely abandoned that endpoint. The tapo brand ones still work (and via talking to the local IP).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.