Error installing Dashboard 2.0 Mac


I'm trying to install Dashboard 2.0 from the Palette Manager and I'm getting the errors shown below. It does seem to be a "permissions" issue but prior to this, I had updated quite a few old nodes and it all worked.

Node-RED version: v3.1.3
Node.js version: v20.11.0
MacOS - Sonoma 14.3

2024-02-01T15:36:31.269Z Install : @flowfuse/node-red-dashboard 1.0.2

2024-02-01T15:36:31.275Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @flowfuse/node-red-dashboard@1.0.2
2024-02-01T15:36:31.416Z [err] npm
2024-02-01T15:36:31.416Z [err]  WARN config production Use `--omit=dev` instead.
2024-02-01T15:36:32.355Z [err] npm ERR!
2024-02-01T15:36:32.355Z [err]  code EEXIST
2024-02-01T15:36:32.355Z [err] npm ERR!
2024-02-01T15:36:32.355Z [err]  syscall
2024-02-01T15:36:32.355Z [err]  rename
2024-02-01T15:36:32.355Z [err] npm ERR!
2024-02-01T15:36:32.355Z [err]  path /Users/rakeshgupta/.npm/_cacache/tmp/b6221b5b
2024-02-01T15:36:32.355Z [err] npm ERR! dest /Users/rakeshgupta/.npm/_cacache/content-v2/sha512/c2/8c/7469ab1557be33a17c9b95aace337019433fd9f8eba761c2077b53ac19c9421edf11b119b4e0339b8de7da23cdaee970f3bfea86599db8b48b110088b931
2024-02-01T15:36:32.355Z [err] npm ERR! errno -13
2024-02-01T15:36:32.355Z [err] npm ERR! EACCES: permission denied, rename '/Users/rakeshgupta/.npm/_cacache/tmp/b6221b5b' -> '/Users/rakeshgupta/.npm/_cacache/content-v2/sha512/c2/8c/7469ab1557be33a17c9b95aace337019433fd9f8eba761c2077b53ac19c9421edf11b119b4e0339b8de7da23cdaee970f3bfea86599db8b48b110088b931'
2024-02-01T15:36:32.355Z [err] npm ERR! File exists: /Users/rakeshgupta/.npm/_cacache/content-v2/sha512/c2/8c/7469ab1557be33a17c9b95aace337019433fd9f8eba761c2077b53ac19c9421edf11b119b4e0339b8de7da23cdaee970f3bfea86599db8b48b110088b931
2024-02-01T15:36:32.355Z [err] npm ERR! Remove the existing file and try again, or run npm
2024-02-01T15:36:32.355Z [err] npm
2024-02-01T15:36:32.356Z [err]  ERR! with --force to overwrite files recklessly.
2024-02-01T15:36:32.356Z [err] 
2024-02-01T15:36:32.356Z [err] npm ERR! A complete log of this run can be found in: /Users/rakeshgupta/.npm/_logs/2024-02-01T15_36_31_398Z-debug-0.log
2024-02-01T15:36:32.361Z rc=243

Any guidance would be appreciated. Thanks for your help

Did you try what it suggests (removing that file). I think it is a cache messed up problem.

1 Like

Yep - tried that and now it's naming different file in the same directory. The directory was empty after I deleted the file.

However, after getting that error message, there is nothing in that directory (8c - zero bytes) and the 'tmp' folder is empty as well.

--- ERROR Message ---

2024-02-01T16:20:40.721Z Install : @flowfuse/node-red-dashboard 1.0.2

2024-02-01T16:20:40.742Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @flowfuse/node-red-dashboard@1.0.2
2024-02-01T16:20:40.933Z [err] npm
2024-02-01T16:20:40.933Z [err]  WARN config production Use `--omit=dev` instead.
2024-02-01T16:20:44.749Z [err] npm ERR! code EEXIST
2024-02-01T16:20:44.749Z [err] npm ERR! syscall rename
2024-02-01T16:20:44.749Z [err] npm ERR! path /Users/rakeshgupta/.npm/_cacache/tmp/6b975fc3
2024-02-01T16:20:44.749Z [err] npm ERR! dest /Users/rakeshgupta/.npm/_cacache/content-v2/sha512/c2/8c/7469ab1557be33a17c9b95aace337019433fd9f8eba761c2077b53ac19c9421edf11b119b4e0339b8de7da23cdaee970f3bfea86599db8b48b110088b931
2024-02-01T16:20:44.749Z [err] npm ERR! errno -13
2024-02-01T16:20:44.749Z [err] npm ERR! EACCES: permission denied, rename '/Users/rakeshgupta/.npm/_cacache/tmp/6b975fc3' -> '/Users/rakeshgupta/.npm/_cacache/content-v2/sha512/c2/8c/7469ab1557be33a17c9b95aace337019433fd9f8eba761c2077b53ac19c9421edf11b119b4e0339b8de7da23cdaee970f3bfea86599db8b48b110088b931'
2024-02-01T16:20:44.749Z [err] npm ERR! File exists: /Users/rakeshgupta/.npm/_cacache/content-v2/sha512/c2/8c/7469ab1557be33a17c9b95aace337019433fd9f8eba761c2077b53ac19c9421edf11b119b4e0339b8de7da23cdaee970f3bfea86599db8b48b110088b931
2024-02-01T16:20:44.749Z [err] npm ERR! Remove the existing file and try again, or run npm
2024-02-01T16:20:44.749Z [err] npm
2024-02-01T16:20:44.749Z [err]  ERR! with --force to overwrite files recklessly.
2024-02-01T16:20:44.750Z [err] 
2024-02-01T16:20:44.750Z [err] npm
2024-02-01T16:20:44.750Z [err]  ERR! A complete log of this run can be found in: /Users/rakeshgupta/.npm/_logs/2024-02-01T16_20_40_913Z-debug-0.log
2024-02-01T16:20:44.756Z rc=243

Try npm cache clean --force

Have you (previously) ran as sudo?

Try deleting the 8c directory altogether

I believe that when installing npm and upgrade node.js I had to use sudo. When running from the palette, I don't see the "sudo" before the npm command though.

EDIT: I have only installed nodes from the palette manager.

That did it! Thanks for your help.

One thing - I did get an error message when I first ran the command.

Your cache folder contains root-owned files, due to a bug in
npm ERR! previous versions of npm which has since been addressed.
npm ERR! 
npm ERR! To permanently fix this problem, please run:
npm ERR!   sudo chown -R 501:20 "/Users/rakeshgupta/.npm"

After I ran the suggested command, I was able to use npm cache clean --force

That was probably the original cause of the problem (the permissions on /Users/rakeshgupta/.npm).

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.