Error with exec command fired from Node-Red

I’m running Node-Red with Home Assistant on Raspberry Pi.
From Node-Red I fire the the following command:
‘echo ds2482 0x18 > /sys/bus/i2c/devices/i2c-1/new_device’
to initialise 1-wire reading.

Earlier this was working without errors but now I get the following error message:
/bin/bash: line 1: /sys/bus/i2c/devices/i2c-1/new_device: “Read-only file system”

If I run
‘echo ds2482 0x18 > /sys/bus/i2c/devices/i2c-1/new_device’
from the terminal, it works just fine.

The problem has started rather recently but I don’t know which operating system or Home Assistant or Node-Red version has starting to make this error.
The problem seems to be related with file-access rights.
Any explanation?

In HA does node red run inside a docker container? If so then if you run that command in a terminal inside the container does it work?

Node-Red has been installed as HA add-on. I'm not an expert but I believe that HA and also the add-ons are run in a docker container.

So does the command work if you run it in a terminal inside the container. I don't know much about docker so you may have to google to find how to run a terminal in the container if you don't know. I generally avoid Docker (and HA).

I'm using the very standard installation available on HA web pages.
As I wrote in the original message, everything worked fine earlier but something
has been changed in some of the recent updates.

You might be best to ask on an HA forum then.