Error with OPC UA nodes connectivity

Hello Everyone,

I'm currently developing some dashboards where we have to fetch data from OPC UA server. Although I'm able to establish the connection, I'm getting the following error in receiving data from some specific nodes in the OPC UA server.
#getConstructor : cannot find constructor for expandedId ns=2; i=15004
#getConstructor : cannot find constructor for expandedId ns=2; i=15004

I'm expecting an array of structures giving x,y&z coordinate values. Since the array has 2 elements, I think I'm getting this error twice.

I also talked to OPC UA server provider and got the following info. The OPC UA server is based on 62541 OPC standard. The Id 15004 refers to the structure which is not getting deserialized in node red. OPC UA server uses binary encoding to encode this structure. Hence I'm getting the values as an array of null i.e. [null, null]. I'm able to get other information like server status, timestamp etc.

Can you please suggest what can be done in order to retrieve this data? Thanks in advance.

Moved to #general as this isn't about developing Node-RED.

I'm getting the following error in receiving data from some specific nodes in the OPC UA server."

You don't actually say which contrib nodes you are using

Hello,

I tried it using node-red-contrib-iiot-opcua & node-red-contrib-opcua.
For node-red-contrib-iiot-opcua, my flow contains an inject node with namespace and index of the node and an opcUaIiot Read node where I'm defining my opc server url.
For node-red-contrib-opcua I'm suing a common inject with OPC UA item and a client. The item has the namespace and index defined. The client has the opc ua server url and action is defined as read.
In the end I'm using message.payload to read the values in both cases.
Using this I'm able to read all the other signals. Also downloaded some sample UA servers and can read most of the stuff I tried. I've a feeling that it has to something with binary encoding but I'm not sure about it.

Have you posted an issue on or searched issues on the node-red-contrib-iiot-opcua repository or the major dependency project Node-opcua repository in GitHub?

I think that's the place(s) you need to go for this one.

U r right. I chcked on Github. There is an already opened issue for support custom data types for OPC UA in OPCUAIIOT contribs. But this is also a problem with normal OPC UA contribs not just with IIOTs. Do you know if there an alternate way to retrieve this data?