Ewpe-smart-mqtt

Hi there!

I've been using this Ewpe-smart-mqtt node for about a month now. It connects nodered and AC units through mosquitto.

Today in the morning, my flows did not work at all, the mqtt push did not actually push anything to my AC unit. Yesterday evening it did.

I tried to debunk it. Seems like the problem is the following:

The npm start listening, and after some time, about 5 minutes, it ends its listening with this error message
MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 message listeners added to [Socket]. Use emitter.setMaxListeners() to increase limit

How can I resolve this? Never had this problem in about a month I've been using this contrib...

Thank you.

What is the full name of that node? Node-red-contrib-?????
Did you check to see if your mqtt broker is running?

Sorry I described it totally wrong, it's an MQTT bridge, I just use nodered to send topic/message to it.

Regardless, the process still stops with that error message.

Even if it's not node-red problem directly, someone might know what this problem is, and how to fix it.

Have you tried opening an issue on their github page. I think you will have a higher possibility of help or a solution over there.

Of course I did, no answer...another fella complained about the same problem (probably), he couldn't get a solve either.

1 Like