Flows stopped due to missing node types (BLE)

#1

I tried to install a node called node-red-contrib-generic-ble and failed to notice that it had a bluetooth dependency that I had not resolved. The installation failed, but then also caused all of my flows to stop with the error, "Flows stopped due to missing node types". I've tried to disable and delete the node but I get "type in use" (its actually not used in any flows now).

Suggestions?

0 Likes

#2

Post the node red log that you get from a node red restart. Paste it here starting from the Welcome to node red message. If you are on a Pi then you can show the log by running node-red-log then restarting node red in another terminal.

0 Likes

#3

Thank you Colin. Here is the log:

(and just to be clear, just solving this dependency is non-trivial -- at this point I'd rather just get rid of this node and get my flows running again)

Welcome to Node-RED
===================

5 Nov 08:57:17 - [info] Node-RED version: v0.19.5
5 Nov 08:57:17 - [info] Node.js  version: v8.12.0
5 Nov 08:57:17 - [info] Linux 4.15.0-38-generic x64 LE
5 Nov 08:57:17 - [info] Loading palette nodes
5 Nov 08:57:18 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
5 Nov 08:57:20 - [warn] ------------------------------------------------------
5 Nov 08:57:20 - [warn] [node-red-contrib-generic-ble/generic-ble] Error: Cannot find module 'bluetooth-hci-socket'
5 Nov 08:57:20 - [warn] ------------------------------------------------------
5 Nov 08:57:20 - [info] Settings file  : /etc/node-red/config.js
5 Nov 08:57:20 - [info] Context store  : 'default' [module=memory]
5 Nov 08:57:20 - [info] User directory : /config/node-red/
5 Nov 08:57:20 - [warn] Projects disabled : editorTheme.projects.enabled=false
5 Nov 08:57:20 - [info] Flows file     : /config/node-red/flows.json
5 Nov 08:57:20 - [info] Server now running at https://127.0.0.1:1880/
5 Nov 08:57:20 - [info] Waiting for missing types to be registered:
5 Nov 08:57:20 - [info]  - Generic BLE
0 Likes

#4

I deduce from that that you have already tried installing the missing bits. There is probably a config node or something in the flow still. You could edit the flow file with a text editor (it is just a json file so with care can be editted) and search for ble or similar strings to find it, then manually delete it from the file. Make a backup of the file first of course. Alternatively it might be simpler just to go back your most recent backup of the flow file and go from there.

0 Likes

#5

thx, appreciate your suggestions. I'll give manually editing the json file a shot.

0 Likes

#6

No need to hand edit. If there's a config node, it'll show up in the config node sidebar as 'unknown' type.

0 Likes

#7

Does the editor work when it is waiting for missing nodes?

0 Likes

#8

Yes, as I recall it does. I will check for sure when I get home later.

0 Likes

#9

If the editor is working then @knolleary's suggestion is the one to follow (as usual). If you still can't find the problem nodes then the search feature may help.

0 Likes

#10

got home, did exactly as @knolleary suggested and all is good. Thanks to both of you.

1 Like

#11

Hello jmesberg,
Did you ever get this Bluetooth LE to work for you. I am trying it out and having similar problems. If you got it to configure ok and deploy, could you possibly post you flow? I am experimenting with one of the bluefruit nrf52's.

Thanks

0 Likes

#12

I get this error as well, but clearly it seems as though these nodes are installed.

0 Likes

#13

I never did get the Bluetooth LE working, but I think its due to some hardware issues on my NUC (or lack of ability on my part to deal with configuring Bluetooth properly on the NUC).

0 Likes

#14

@jfehl Could you post the following?

0 Likes

#15

I do also have NUC (intel) with Windows 10 installed and I've got the same issues with all the bluetooth nodes from the market :expressionless: . Nodes just disapear after the first deploy, getting Unknown.

0 Likes

#16

Then perhaps you could post what @colin asked for

0 Likes

#17

There is one warning...

14 Feb 00:05:11 - [warn] [node-red-contrib-generic-ble/generic-ble] Error: Cannot find module 'bluetooth-hci-socket'

 14 Feb 00:05:11 - [info] Waiting for missing types to be registered:
 14 Feb 00:05:11 - [info]  - Generic BLE
 14 Feb 00:05:11 - [info]  - Generic BLE in

I tried install the missing bluetooth-hci-socket module, but it fails on finding python. I'll try it tomorrow.

0 Likes

#18

Post the whole log from the welcome message please.

0 Likes