Force node-red to English?

Hello,

I am in the process of moving my node-red from a raspberry installation into a docker container on a more powerful machine.
I got the container up and running, still need to migrate data. But what struck me first is that it appears localised (German) which I don't like at all. How can I force it to appear in English?

thanks!

Thanks! Maybe that was introduced in a newer version because my raspberry still runs an older one.
Changing language priorities in the browser helped.

I got the same problem as jaeti01 after I upgraded to Node-RED to 0.2. I am using chrome browser. Changed the language of the browser to English but Node-Red-Editor is still in German. If you are used to English it is very annoying to get it in German :-(.

We only introduced the German translations in 0.20. We assumed it would be a welcome contribution, but it has generated a surprising amount of negative feedback.

Previously we only had English, Japanese and Chinese translations - so there had never been a request for the editor to ignore the user's own preferred language (as the browser identifies) and provide it in another one.

In the short term, we will provide a option via the settings file to force it to a particular language.
In the long term, we will add an option in the editor itself to set the preferred language.

2 Likes

Actually changing the language order in chrome solved it for me.
And i appreciate the effort of translation. It’s more my personal preference to have development environments in English.

I'd like to second the humble request to provide an option for the editor language. Case in point, 'Verzögerung' is longer than 'Delay' and flows that have been designed in the past in English now appear in German more cluttered.

1 Like

Yes the choice is work in progress. Meanwhile also see this pull request https://github.com/node-red/node-red/pull/2159

Is there some file that I can patch without having to change the browser language?

If you don't want the german translations search for all the locales/de directories and delete them.

2 Likes

Thanks!

❯ sudo rm -rf /usr/lib/node_modules/node-red/node_modules/@node-red/{editor-client/locales/de,nodes/locales/de,runtime/locales/de}

1 Like