Gauge wont update

Hi everyone,

I have a compass gauge on my dashboard which wont update when a new value arrives.
The gauge only changes after FULL deploy. It doesn't respond to any value after that.
The gauge label does update.
A text node on the same dashboard gets the same value and that does update.

I have replaced the gauge with another one, thinking the gauge might be corrupt, but that only worked a couple of times and then the same.
Changing the gauge from compass to gauge, donut or level doesn't matter either.
Rebooting the RPI didn't help either.

I'm kinda lost on what to do next.
Anyone got any ideas?

The investigation starts with knowledge about the versions of the related parts. (Nodejs, Node-Red, Dashboard.)
It also takes to see what is the payload you are sending to the gauge.

A snapshot of your flow would be useful too.

Node red V2.2.2
Nodejs V16.15.0

The gauge gets a number
in the gauge I use the toFixed(1). But without that it also does not update

Inject node send an object, function node calculates distances and creats new msg for gauge bearingToWaypoint


I delete everything from the object in the function node and only output results

From the ui-qauge Help tab:


Adds a gauge type widget to the user interface.

The msg.payload is searched for a numeric value and is formatted in accordance with the defined Value Format, which can then be formatted using Angular filters.

For example : {{value | number:1}}% will round the value to one decimal place and append a % sign.

That solved it.
Thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.