Got up this morning and NR is not working

#1

Yesterday evening all was ok.

This morning I got up and didn't really take too much notice but I got home abut 11:00 (local time) and tried to connect to my main NR machine.

This was brought on by a device which talks to NR (and vice versa) wasn't playing the game and the display was turned off.

So I thought I would look into it.

Page refused to load.

Looked at the syslog and saw this (again: see attached.)
I haven't done anything to it in the mean time.

I have rebooted, powered down, waited and powered up the machine.

NR still refuses to show me a web page.

This is what NR tells me if I ask for a status:

pi@TimePi:~ $ sudo systemctl status nodered.service
● nodered.service - Node-RED graphical event wiring tool
   Loaded: loaded (/lib/systemd/system/nodered.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2019-02-12 12:19:45 AEDT; 54s ago
     Docs: http://nodered.org/docs/hardware/raspberrypi.html
 Main PID: 1679 (node-red)
   CGroup: /system.slice/nodered.service
           └─1679 node-red

Feb 12 12:19:58 TimePi Node-RED[1679]: 12 Feb 12:19:58 - [info] Linux 4.14.79+ arm LE
Feb 12 12:20:04 TimePi Node-RED[1679]: 12 Feb 12:20:04 - [info] Loading palette nodes
Feb 12 12:20:30 TimePi Node-RED[1679]: 12 Feb 12:20:30 - [info] Dashboard version 2.13.2 started at /ui
Feb 12 12:20:32 TimePi Node-RED[1679]: 12 Feb 12:20:32 - [info] Settings file  : /home/pi/.node-red/settings.js
Feb 12 12:20:32 TimePi Node-RED[1679]: 12 Feb 12:20:32 - [info] HTTP Static    : /home/pi/.node-red/public
Feb 12 12:20:32 TimePi Node-RED[1679]: 12 Feb 12:20:32 - [info] Context store  : 'default' [module=memory]
Feb 12 12:20:32 TimePi Node-RED[1679]: 12 Feb 12:20:32 - [info] User directory : /home/pi/.node-red
Feb 12 12:20:32 TimePi Node-RED[1679]: 12 Feb 12:20:32 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
Feb 12 12:20:32 TimePi Node-RED[1679]: 12 Feb 12:20:32 - [info] Flows file     : /home/pi/.node-red/flows_TimePi.json
Feb 12 12:20:33 TimePi Node-RED[1679]: 12 Feb 12:20:33 - [info] Server now running at http://127.0.0.1:1880/
pi@TimePi:~ $ 

But when I try to go to the URL...

(See picture 1)

Sorry, but I'm stumped.

#2

Looks like you have the same problem I had last night, except mine started at midnight by turning on and off because I have it so that if it shuts down it automatically starts back, so guess how I felt... any way the problem is the bigtimer node I downgraded mine to 2.0.8 and that fixed the problem. to revert back if you are unsure you do the following a a prompt npm install node-red-contrib-bigtimer@2.0.8 of to what ever version you like.

#3

Yeah, funny you should mention that.... Bigtimer.

I found posts on it and this is a confusing thing I just saw:
Given there is problems with a new(er) version and all that, I decided to try "rolling it back" to 2.0.9 with npm from the CLI.

But I'm confused with what the CLI is telling me.
Not sweating on it too much, as it does seem to have fixed the problem, I don't get why I am being told something different to what is* happening.
npm install .......@2.0.9
Removing .... @2.1.3 from the tree as **it is been replaced by a newer (version?)
2.0.9 is newer than 3.1.3?

#4

Just as a follow up on that.

That was on "machine #1"

Looking on this machine I have bigtimer 2.1.1 and it seems to be ok.

So maybe you could get away with 2.1.1. How 2.1.3 got on my machine is interesting.
Maybe I did update it, but can't be sure.

I am updating that machine to 2.1.1 and shall indicate if all is good or not.

pi@TimePi:~/.node-red $ npm install node-red-contrib-bigtimer@2.1.1
npm WARN node-red-project@0.0.1 No repository field.
npm WARN node-red-project@0.0.1 No license field.

+ node-red-contrib-bigtimer@2.1.1
updated 1 package and audited 876 packages in 221.82s
found 6 low severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details


   ╭───────────────────────────────────────────────────────────────╮
   │                                                               │
   │       New minor version of npm available! 6.4.1 → 6.7.0       │
   │   Changelog: https://github.com/npm/cli/releases/tag/v6.7.0   │
   │               Run npm install -g npm to update!               │
   │                                                               │
   ╰───────────────────────────────────────────────────────────────╯

pi@TimePi:~/.node-red $ node-red-stop

Stop Node-RED
 
Use   node-red-start   to start Node-RED again
 
pi@TimePi:~/.node-red $ node-red-start
.
.
.
.

Waiting now for NR to get back.

pi@TimePi:~/.node-red $ node-red-start

Start Node-RED
 
Once Node-RED has started, point a browser at http://192.168.0.99:1880
On Pi Node-RED works better with the Firefox or Chrome browser
 
Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot
 
To find more nodes and example flows - go to http://flows.nodered.org
 
Starting as a systemd service.
Started Node-RED graphical event wiring tool.
12 Feb 13:19:21 - [info]
Welcome to Node-RED
===================
12 Feb 13:19:21 - [info] Node-RED version: v0.19.5
12 Feb 13:19:21 - [info] Node.js  version: v8.12.0
12 Feb 13:19:21 - [info] Linux 4.14.79+ arm LE
12 Feb 13:19:26 - [info] Loading palette nodes
12 Feb 13:19:52 - [info] Dashboard version 2.13.2 started at /ui
12 Feb 13:19:55 - [info] Settings file  : /home/pi/.node-red/settings.js
12 Feb 13:19:55 - [info] HTTP Static    : /home/pi/.node-red/public
12 Feb 13:19:55 - [info] Context store  : 'default' [module=memory]
12 Feb 13:19:55 - [info] User directory : /home/pi/.node-red
12 Feb 13:19:55 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
12 Feb 13:19:55 - [info] Flows file     : /home/pi/.node-red/flows_TimePi.json
12 Feb 13:19:56 - [info] Server now running at http://127.0.0.1:1880/
12 Feb 13:20:06 - [info] Starting flows
12 Feb 13:20:18 - [info] [udp out:1095c327.4fb3f5] udp ready: 192.168.0.21:6723
12 Feb 13:20:22 - [info] Started flows
12 Feb 13:20:26 - [warn] [function:4ac3b17.7ec8c5] ********************
12 Feb 13:20:26 - [warn] [function:4ac3b17.7ec8c5] Azimuth set to 55
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **
12 Feb 13:20:26 - [warn] [function:Button Colour] **  Reset button colours **

2.1.1 works ok.

#5

I had the same issue over the weekend. I updated bigtimer and it went away.

1 Like