GPIO and raspberry pi 5

I try to use the default GPIO pin-out and get the message : "nrgpio python command not running".

obviously I'm doing something wrong, or I'm forgetting to install some basics into the Raspberry Pi.

How can I get this working? Does it need another type of Node?

Currently, you can't use GPIO pins on a Pi5

There are several discussions going on at the moment
Here are two

Can someone test if the node-red-node-gpiod node does work on Pi5 as that uses libgpiod

Just installed pigpio and then then node-red-contrib-gpiod and it didn't work :frowning:

Already reported as an issue

I've followed a few threads on the Pi forum and I have managed to get the standard gpio node to work (Tested output on Pin 11 and input on Pin 23 using a Pibrella add-on board)


So what I did was from a termiinal

sudo apt remove python3-rpi.gpio

to remove the old RPi.GPIO module

and then

pip3 install --break-system-packages rpi-lgpio

which is supposed to be a drop-in replacement for the old module
I tried several methods to install rpi-lgpio and this was the one that worked for me :slight_smile:

I've re-booted my Pi and it still works :slight_smile:


dear Simon,

This works for GPIO out on/off. thank you very much, this solves a big part of the issues we encounter to control our lab. However, using GPIO in (to connect to my puls flow meters) doesn't work.

Do you have the same solution to this as well?

Thanks in advance for all your support.


What make model of pulse flow meters have you got - what do they output?

Have you ever had them working before on a older Pi?

As shown in my post above, I can detect a simple input being 1 or 0 (3.3V or 0V)

1 Like


my mistake, had to make the gpio Pull-Up.

1 Like

Nice - the readme says that there should be a package available in the apt repo - Installation — rpi-lgpio 0.4 Documentation - but I can't find it...

I wonder how cross platform (on Pi) this is... as-in would it also work on Ubuntu on Pi or Debian on Pi ?

Also is it only for bookworm onwards ? or would it work on "older" installs. I.E. if I make the script switch over to this/force install lpgio on anything with a BCM processor... ? Thoughts ?

I know nothing :slight_smile:

Except that the documentation doesn't match up with my real world experience with it so far :slight_smile:

Well you have pi5 so are miles ahead of me

1 Like

In the notes you linked to the first release was 2022-10-14 - before bookworm ?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.