GPIO ouput pin does not change state

Hello everyone!
I wonder if someone has faced the following issue:

I am activating a GPIO output with a MQTT message:

So when a message with a specific topic arrives, "filter timer..." node sends a "1" to the GPIO node for a period and then a "0" to turn on the pin timely.
The issue is that I send ones and zeros to the GPIO node and the correspoding pin does not actually change its voltaje to 0 nor 3.3 V. I faced this problem last month and solved it by changing interface settings for GPIO remote server for it to be enabled. Nevertheless two days ago it suddely stoped working again. I setup remote GPIO server againd and upgraded apt list. Nothing worked.

What is weird is that there are no error messages in node red nor in the node iindicator led (it changes to 0 and 1 accordingly with the messages, but the pin still does not change voltaje).

I am using a Rpi Zero rev 1.3

If you simply stick two inject nodes into the GPIO node with msg.payload set to 1 and 0 - does the pin change voltage?

I just read this bit
What do you mean by"GPIO remote server"?

Are you using the standard Pi GPIO node or something else?

Does it work with another pin ?

Hi! Thanks for your answer.
About the GPIO remote server:
This is in raspi-config screen, under interface settings. There you will find Gpio remote acces/server.

I am using the regular gpio nodes that come with the instalation.

Hello! Thank you for the answer. No, it does not work for another pin.
When I solved this last month, it got solved also for every pin.

If I simply inject payloads as you firstly say I got the same results.
The node icon does change the indicator (the indicator changes to 1 and 0 accordingly, but the voltage does not change)

Also must add that if I control the GPIO pins with Python code from the console, pins work properly. So it seems to be something with node red.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.