Raspi 2B+ node-red-node-pi-gpio does not send msg when pin status was changed

I tried using node-red-node-pi-gpio to read pin status and it should send a 1 / 0 msg. But it doesn´t send any msg when changing pin status. rpi.gpio is installed and reading pin with the bash does give me a good result:

pi@raspberrypi:~ $ gpio -g read 17
pi@raspberrypi:~ $ gpio -g read 17


[{"id":"e1dea395.599e18","type":"tab","label":"Flow 1","disabled":false,"info":""},{"id":"924550cf.a78b68","type":"debug","z":"e1dea395.599e18","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","x":550,"y":400,"wires":[]},{"id":"51cc70b4.a2b138","type":"inject","z":"e1dea395.599e18","name":"","topic":"","payload":"test","payloadType":"str","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":390,"y":360,"wires":[["924550cf.a78b68"]]},{"id":"a9821f03.1c561","type":"rpi-gpio in","z":"e1dea395.599e18","name":"","pin":"11","intype":"tri","debounce":"25","read":false,"x":390,"y":420,"wires":[["924550cf.a78b68"]]}]

Did I miss something ?

Node-red uses physical pin numbering which can be the reason that nothing seems to happen

thank you for your answer. This are my node settings:
click me
this is where I connect the pins:
click me
I dont see a mistake.

You may need to add a pull-down resistor to prevent the GPIO from floating.

I solved it like this:
uninstalled node-red-node-pi-gpiod 1.0.6 (The basic Node-RED node for Pi GPIO)
installed: node-red-node-pi-gpiod 0.0.13 (A node-red node for PiGPIOd)
npm install node-red-node-pi-gpiod
sudo nano /etc/rc.local added line:
restarted the pi, tested with telnet if port 8888 is running.
implemented nodes and works...

Well there's at least one typo in your post :slight_smile:

I think you meant to say you uninstalled the standard node-red-pi-gpio node and installed the node-red- pi-gpiod alternative node

So good you've got it working but its not good that the standard one didn't work

How did you install Node-RED?

[edit sorry for the typo I made!]
[2nd edit to remove superfluous question about Pi model!]

You are right ... Sry for bad english my motherlanguage is german.
I made a clean installation of Raspbian, MQTT, Node-Red on my Raspi 2 B+

Mine Deutsche ist sehr nicht euer English :slight_smile:
Did you install using the script from here?


haha, nice try .... OK, I think my english is better than your german :slight_smile:
Yes I used the link of your post to install node red ^^ :slight_smile: