Greenhouse irrigation


#61

Hi Paul:
Did you have a problem with the arduino IDE finding tools/esptool/esptool.exe?


#62

Is this a library used by ESPeasy?
If so, I haven't tried ESPeasy yet, so no.
Maybe @dynamicdave would be the best person to ask, as he uses ESPeasy.

Paul


#63

The issue was ArduinoIDE v1.8.5 not finding the file to upload the app. I switched over to an older version, v1.6.12 and it works fine. Go figure. This is the second time the ArduinoIDE has bitten back.
Looking for eapeasy now. :smile:


#64

I use a Mac and have been using the esptool.py command line i to do y initial load of ESPeasy. From then on, I do the OTA updates. This is so much easier than coding a new xxx.ino file for each Wemos and trying to keep track of which is which.

Now if I can just figure out how to flash a Sonoff....

Paul (aka zenofmud)


#65

This is funny. I searched all over the web looking for esptool.exe and couldn't find it. I switched to ArduinoIDE v1.6.12 and got a simple blinker to upload so I downloaded espeasy and unzipped it and there it is. I may be able to use v1.8.5 after all.
Now, what bin to pick????


#66

Here is the link to the mega version releases. I'm currently using the latest.

esptool is python - here is the link : https://github.com/espressif/esptool


#67

OK, got that done. Trying to find how to connect to the wemos D1 now.


#68

I tend to plug the Wemos directly into the USB port on my laptop and use the "flasher" program that comes in the same bundle as ESP Easy.
i.e. When you unzip the firmware you should see an app called ESP8266.
If you run this it asks for the Port number your Wemos is plugged in to and the filename for the firmware.

You don't need to put the Wemos into programming mode as the Wemos has a interface-controller-chip on-board that does it all for you.
Once you have flashed the device it should create a WiFi hotspot that you can connect to and then login to the Control panel at URL 192.168.4.1
Here you can setup details of your primary and secondary WiFi networks, node name etc. then reboot the unit.

You should now be able to login to the Wemos on your normal network and finish-off the settings.


#69

which won't run on a mac :sob: and then you have to use esptool.


#70

For anyone using SSRs this cautionary tale is worth reading.


#71

I received a set of five Wemos D1 Minis last week, and have just got round to flashing them.

I think I may have ordered the incorrect version (think they are pre-flashed with Lua) as I've had a lot of trouble trying to flash them with my normal flasher.

I finally found this program that flashes the device and sets-up all the networking stuff all in one go.

https://github.com/Grovkillen/ESP_Easy_Flasher

I've managed to flash all five devices with this program - yipppppeeee.

PS: Sorry Paul, this program is for Windows only.


#72

No, that's good news! I use Windows 10 too.
My delivery arrived this morning too, so I'm going to try the same tonight.

I see that ESPEasy_R120.zip contains 3 bin files, which did you use for the Wemos D1's?

EDIT - Aah, you meant the other Paul! (zenofmud


#73

I use the ESPEasy Mega release - it gets updated every few days.
There was a new release today (1st Aug)

PS: I ordered some more Wemos D1 Minis from Banggood in China last night as they are on offer at £2.71 each !!!

Cheers from David


#74

I've just had 5 delivered @ £1.91p each, free postage.
Search for 'GREATZT' store in AliExpress.

Also, they only took 2 weeks from order to delivery.


#75

Hi Paul-Reed,
That's a brilliant price - I thought mine was good, but yours is even
better.
Just checked they are listed at £1.89.

Cheers from David


#76

Hi to Paul-Reed,
I use my Wemos devices on breadboards.
I use the headers with the very long pins.
Push them through the top of the board and solder underneath, they then
fit really nicely on a breadboard.

As I said in a previous post, I had trouble flashing these units as they
were pre-flashed with Lua.

This Windows program helped me flash them.


#77

Great Price, thanks for sharing Paul!


#78

Note: some of these really cheap ones are clones of the real wemos d1. While I’ve not had a serious problem with mine, one or two have failed to drive things like a neopixel so I suspect the clock timings may not be very accurate. (Not seen problems with WiFi or programming or sensors like ds18b20 etc)


#79

The vast majority floating about in Ebay, AliExpress, etc seem to be clones, but I haven't had any problems with them, and they do seem well constructed.
The most obvious test of copies, is that they are square cut PCB's, whilst the original Wemos PCB has rounded corners at the top...


#80

I've bought over 30 of these devices during the last year from Banggood.
They are used with ds18b20, LCD via I2C, push-buttons, driving LEDs and relays, and reading analog values.
Apart from one where the miniature push-button was stuck - they have all worked fine.
I've just checked the shape of the PCBs.
I seem to have a mixture of curved ends and diagonal cuts.
The PCB construction and soldering looks the same across all the devices I have.