HELP Lost everything

Lost everything. Was trying to update the cronplus to the latest version but somehow managed to scr... it. Lost everything. I then imorted my backup from latest night as I do send backup to dropbox. But when I import the project and deploy it, most seems fine but nothing works. If I push on a injectnode I get the message: Error Node not deployed. And i also get the message tha chronplus is missing even if the latest version now is installed. What to do?

Best regards

It also tells me: Flows stopped due to missing node types.

  • cronplus


and in the debug windows i read: stopped modified nodes waiting for missing types to be registered. info cronplus

Simply install node-red-contrib-cron-plus from the palette manger.


As for "losing everything" - if you had asked on the forum we could have told you where to look (there is a single local backup of your flows, updated with each deploy - this will now be lost due to your actions)

Ok, but it all is in the backup from last night. So I think that will be fine if I can get things up running again. I have installed the cronplus again, but get some errors.
Last version of cronplus was 1.5.5

The "cannot get description from node-red" suggests that node red not actually running. Have you checked to see if node red is still running?? How do you launch node red from a command line? Are there any errors at the end?

removed the cronplus nodes as there is only a few of them, then everything except from cronplus is running. Removed cronplus and tried a reinstall, but then get this:


2022-07-08T11:13:01.796Z Install : node-red-contrib-cron-plus 1.5.7

2022-07-08T11:13:02.766Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-contrib-cron-plus@1.5.7
2022-07-08T11:13:06.617Z [err] npm
2022-07-08T11:13:06.617Z [err] WARN registry Unexpected warning for Miscellaneous Warning EINTEGRITY: sha512-xqCmwfG8KVNzlFfdkdNQE2zaXxcHFM31/yLNW+AsV5qsrqAcBAGIyeZ8YxrKOF94mlN66YO8bTGmgEZJJT73OQ== integrity checksum failed when using sha512: wanted sha512-xqCmwfG8KVNzlFfdkdNQE2zaXxcHFM31/yLNW+AsV5qsrqAcBAGIyeZ8YxrKOF94mlN66YO8bTGmgEZJJT73OQ== but got sha512-z4PhNX7vuL3xVChQ1m2AB9Yg5AULVxXcg/SpIdNs6c5H0NE8XYXysP+DGNKHfuwvY7kxvUdBeoGlODJ6+SfaPg==. (0 bytes)
2022-07-08T11:13:06.617Z [err] npm
2022-07-08T11:13:06.617Z [err] WARN registry
2022-07-08T11:13:06.617Z [err] Using stale data from due to a request error during revalidation.
2022-07-08T11:13:06.698Z [err] npm
2022-07-08T11:13:06.698Z [err] ERR! code EINTEGRITY
2022-07-08T11:13:06.698Z [err] npm ERR!
2022-07-08T11:13:06.698Z [err] errno EINTEGRITY
2022-07-08T11:13:06.747Z [err] npm
2022-07-08T11:13:06.747Z [err] ERR! Invalid response body while trying to fetch Integrity verification failed for sha512-xqCmwfG8KVNzlFfdkdNQE2zaXxcHFM31/yLNW+AsV5qsrqAcBAGIyeZ8YxrKOF94mlN66YO8bTGmgEZJJT73OQ== (/home/pi/.npm/_cacache/content-v2/sha512/c6/a0/a6c1f1bc2953739457dd91d350136cda5f170714cdf5ff22cd5be02c579aacaea01c040188c9e67c631aca385f789a537ae983bc6d31a6804649253ef739)
2022-07-08T11:13:06.929Z [err]
2022-07-08T11:13:06.929Z [err] npm ERR! A complete log of this run can be found in:
2022-07-08T11:13:06.929Z [err] npm
2022-07-08T11:13:06.929Z [err] ERR! /home/pi/.npm/_logs/2022-07-08T11_13_06_748Z-debug.log
2022-07-08T11:13:06.943Z rc=1

You have an issue with your package.json-lock file (this is easy to understand if you search

In your .node-red folder,
Delete the package-lock.json file then run npm install and then npm install node-red-contrib-cron-plus

can not find that file in the folder. Thes files are my backup-files can i import them all?


No. That's possibly why you have an issue.

Do what I said...

can i run the npm install from the debug window on my pi?

(finally understand the feelings my students must have when i ask them, why did you do that, wait for help...)

What is a debug window? Do you mean an S SH terminal? Where is node-red installed?

the node red is on a Raspberry pi. So I wondered if I coud do it from the pi, but i can ssh it.

Change your file viewer to show file extensions, that will make life easier.

If you are not doing it via ssh then how are you doing it?

used the commandwindow on the raspberry pi itself. Works, but my card crashed so I am now on a new install and importing my backup. Had to reinstall a lot to the pallette but encounter a new problem.


Guess it has to do with my Home Assistant. Tried three different installs in the pallette but still the same.

Did I learn something? Hopefully! But I am extremely happy that I do have automatic backup to dropbox every night. Took a clean install, installed all missing contrib nodes, and then imported the flow. A little bit work with access keys but now everything is up running again. Note to self, make a note listing all contrib nodes in use. Thanks to everyone who replied in here.

If you backup everything in the .node-red directory except the node-modules folder, then to restore you just need to restore that directory, then go into the directory and run
npm install
and it will install all the contrib nodes you had before.


Thank you :slight_smile: I guess I did it difficult for myself yesterday, but somehow I managed to pull it together. Learned a lot but still a lot to learn.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.