Hola buenas ,soy nuevo en node red alguien sabe , porque me sale este tipo de error en mi dashboard cuando le doy deploy, la imagen svg de mi scada no me sale en mi dashboard ,por favor alquien me ayuda ,

Hello good, I'm new to node red, does anyone know, why I get this type of error in my dashboard when I give it deploy, the svg image of my scada does not appear in my dashboard, please someone help me,

flows .json (74.5 KB)

I'm not sure if it is only me, but I am not seeing the pictures.

All I see is Uploading: Capture de pantalla 2022-11-10.....png(1)
and so on.

ahi estan las fotos amigo , ese error tengo con node red en dashboard

Oh, something has changed since I posted my reply.

Originally the pictures weren't there. Now they are.
Good they are there now.

The last picture. Not very helpful, sorry.

You need to copy/paste that here so it can be really seen.

How to do that:

Select all the text. (I hope you know how to do that)
To paste it here correctly, look at the top of the area where you are entering the text.
There are buttons: a talk bubble, a BOLD indicator, an ITALIC indicator, a chain/link indicator, a QUOTE indicator then there is the CODE indicator: </>
Press it.
Press <enter>
Paste the text/code/error
Press <enter>
Press that button again.

You should see something like this:

This is what you just pasted
line 2 of the text
line 3
and so on

All being good, you can then post the reply.

Ok, you did post the flow.
Problem: ui_svg_graphics node....
I can't find it in the library online.

Could you give the full path/name to that node?
(Though if it is svg, it will most likely be above my skill set)

1 Like

I think the node he is using is this one...

Have you tried any of the examples that come with the SVG node to see if they work in your setup?

1 Like


From your screenshot it appears to me that your error is caused here in my code:

if(ui === undefined) {
   ui = RED.require("node-red-dashboard")(RED);

So it cannot find your dashboard. I remember something about this in the past. Could it be that you have installed my svg node, and you have installed the dashboard afterwards? If so it might be that restarting your node-red instance might help, or clearing your browser cache.

If anybody else remembers what could cause this, please share it here.
My lunch break is over...


probe con un ejemplo y es el mismo error amigo

de igual manera borre el cache de mi navegador ,y sigue el mismo error amigo

Hi @jhoningMTN,
had a similar question in the past from somebody else, but cannot find it anymore.

I don't have much knowledge about this, so I can only give you some high level tips/questions:

  1. You still haven't answered my question above: Could it be that you have installed my svg node, and you have installed the dashboard afterwards?
  2. Have you already tried to restart Node-RED?
  3. Do you see any errors in your browser's console log?
  4. Can you use other ui nodes succesfully? I mean other ui nodes that you can install extra via the palette menu (like ui-led, or ui-multistate-switch, or...).
  5. Are you using the official node-RED dashboard (and not one of the other dashboards like mdashboard)?
  6. Can you install the dashboard again (via command line) and see if that helps?

If that doesn't help, then I don't think I can offer much other support anymore. I am running out of creativity. Perhaps @dceejay knows some other things you can try...

BTW I am dutch speaking, but I try do my best to support everybody in English. Could you please translate your feedback to English, to avoid that me and all the other community members have to do it... Thanks!

1 Like

Hola Bart Butenaers ,gracias x tus ayudas ,pero me funciono la pregunta de alto nivel opcion1.
Muchas gracias amigo ,eres un genio!!

1 Like