How to keep the volume of alexa messages constant

  • How to keep the volume of alexa messages constant, always at the same level?

  • Sometimes the volume of the echodot at home is lowered either by voice command or manually with the button and no longer restored, when an alarm message arrives then it is not heard.

  • I've read that there is a particular function to activate from the alexa app, the adaptive volume, but it seems to work only in the U.S. and not in my country.

  • I tried in the alexa speak routine the command Volume announcement set but I got only the adjustment of the sound alert before the message.

  • Can you tell me the correct command to use?

Sorry, Im struggling to understand what this has to do with Node RED?
Shouldn't you be asking Amazon or some Amazon Alexa community on how to control Alexa's volume

Unless I am completely missing something?
If I am missing something - then you need to provide more in your thread.

You are not really clear on which nodes you have tried or are using.
The alexa remote2 nodes allow speakAtVolume, using a routine node you can send a custom json.

Or use the preset speakAtvolume typed inputs.

@E1cid Now it makes sense :sweat_smile:

When starting a thread, always add some context about your setup to your question, to help those passing by

@marcus Excuse me if I did not put examples , but I just made some tests ,@e1cid I use this node node-red-contrib-alexa-remote2-applestrudel , I tried speak at volume but I get only the change of the beep before the message.

If you look at the help info you will see -

  • Speak At Volume or Volume with the Add mode can only change the volume if the echo has recently been active playing music!

Based on the fact that you mention "the beep before the message" then I assume you are using the announcement option ?

  • Announcement and SSML speak options will speak to all devices if you don't specify any device (does not work with Speak At Volume)

So this may be your issue.

You need to send type regular and use set mode, or custom routine.
This works fine for me

[{"id":"f9fc24c34d19b761","type":"alexa-remote-routine","z":"da8a6ef0b3c9a5c8","name":"","account":"c8738129.d902c","routineNode":{"type":"speakAtVolume","payload":{"type":"regular","text":{"type":"str","value":"With the Custom"},"volume":{"type":"num","value":"70"},"mode":"set","devices":["G090LF1182850C6D"]}},"x":190,"y":1420,"wires":[[]]},{"id":"11fcee5069184309","type":"inject","z":"da8a6ef0b3c9a5c8","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"","payloadType":"date","x":100,"y":1360,"wires":[["f9fc24c34d19b761"]]},{"id":"c8738129.d902c","type":"alexa-remote-account","name":"alexa remote 2","authMethod":"proxy","proxyOwnIp":"localhost","proxyPort":"3456","cookieFile":"","refreshInterval":"14","alexaServiceHost":"","amazonPage":"","acceptLanguage":"en-GB","onKeywordInLanguage":"","userAgent":"","useWsMqtt":"on","autoInit":"off"}]
1 Like

thanks for the info , tomorrow morning I will try your examples and report back now I can not .

What no JSONator for this :wink:

1 Like

Thank you e1cid :+1: ,
it works perfectly was just what I was trying to do, I had tried regular and ssml without getting any result perhaps, I had also tried the parameters set and add.

yes I had chosen the 'Announcement option,
it is by reading the instructions commented that I got the' idea that it was a command that worked only after a music playback. I'll allow myself ... but if they had written in another way that 'Announcement' is inherent to the 'acoustic warning, and that 'regular' intervenes on the message announced the newbies like me, would not have to stress people on the forums ... :grin:
P.S. I didn't understand the sense JSONator .... I'm Italian unfortunately !!!

1 Like

JSONata is a Lightweight query and transformation language for JSON data.

It can be used in a lot of node-red nodes.

@smcgann99 was making a joke, as a lot of my replies i use it. Normally where it is easier to do so rather than a function node. In this example there was no need for either.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.