How to not display refresh page in kiosk mode when i want to see dashboard nodered?

I'm setting up a pi to run in kiosk mode as per the instructions in dashboard nodered.
I use this link :Can I delay chromium in kiosk mode? - Raspberry Pi Forums

Unfortunately the refresh page is displayed.
what am i doing?

My start-chromium.sh file is:
#!/bin/bash
echo "Starting chromium in 5 seconds..."
sleep 5
while :
do
chromium --noerrdialogs --kiosk http://192.168.31.144:1880/ui
done

I hope someone can help me.
Thanks.

Welcome to the forum @faezehFrj

What refresh page?
Under what circumstances are you running the script? Is this on boot or something?
If it is on boot and you rerun the script later does it work? If so then you need to make the delay longer. Have a look in /var/log/syslog to see how long after boot node-red starts up.

Hello.Thanks for your immediately response.I mean that when raspberry pi boot up i wand show my dashboard since my nodered want several seconds to service,one page displayed that show:
"This site can't be reached"
(Ip address) refused to connect
try:
-checking connection
-proxy and firewall
ERR_connection_refused

But after a few seconds, the dashboard appears .
my code is that i wrote in autostart :

/usr/bin/chromium-browser --kiosk  --disable-restore-session-state http://localhost:1880

is my solution correct?do you have another way?

As I said in my previous post you probably just need to increase delay to give node-red time to get going. If you time how long it is before it works if you keep refreshing then you will get an idea of how long you need to wait. Probably you need something like 30 seconds.

Unfortunately this solution does not work.I follow exactly the instructions and instructions of this link that i post befor but it does not go in kiosk mode at all.
My start-chromium.sh file is:

#!/bin/bash
echo "Starting chromium in 5 seconds..."
sleep 30
chromium --noerrdialogs --kiosk http://localhost/ui &

and my autostart file is:

lxpanel --profile LXDE-pi
pcmanfm --desktop --profile LXDE-pi
xscreensaver -no-splash
/home/pi/start-chromium.sh

Where am I doing wrong?

Has the longer delay fixed the unable to connect problem?

You have forgotten the port 1880 specification. With the port, that command works for me (in Ubuntu). If you type that command in manually does it work? If not then what happens?

oops.i know, when i want to write this post, i miss it.
It seems that it does not enter the file at all and the code is not executed.I delete delay,it dose not work :sleepy:

Does the chromium command line work if you enter it in a terminal (just the chromium line).

finally I change my solution .I use this link >Raspberry Pi Kiosk using Chromium - Pi My Life Up
and add sleep 5 in this file and in the end it worked right.
Thank you for your time.