Http request node get server not responding error

I have a flow that is being used by some one else but getting :
msg.payload : string[71]

"RequestError :"

10/10/2023, 21:04:00node: e9f91fa8e7a0868emsg : string[23]

"no response from server"

He exported his flows and I do not get the error and the flow works as advertised.

I had him try the http fetch using curl


and he is getting a response from the cli.

At this point I am out of ideas on why we are seeing the 'no response from server'

He is running:
$ node -v

$ npm -v

adrian@debian:~/.node-red$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux trixie/sid
Release: n/a
Codename: trixie

The dashboard is v3.1

Here is the connect nodes from the flow. I can't post the flow as it is too large.

[{"id":"fb18dbd73fa0cefc","type":"inject","z":"aa40d03efc6fc57a","g":"fdad09b49a9de54f","name":"5 min","props":[{"p":"payload"}],"repeat":"300","crontab":"","once":true,"onceDelay":"30","topic":"","payload":"","payloadType":"date","x":110,"y":820,"wires":[["ea2c2b9611a21d17"]]},{"id":"b283be29b27dbc95","type":"http request","z":"aa40d03efc6fc57a","g":"07709eb082c3c556","name":"ConnectOut","method":"GET","ret":"txt","paytoqs":"ignore","url":"","tls":"","persist":false,"proxy":"","insecureHTTPParser":false,"authType":"","senderr":false,"headers":[],"x":270,"y":400,"wires":[["d7891f1a41b15ad0"]]},{"id":"d7891f1a41b15ad0","type":"function","z":"aa40d03efc6fc57a","g":"07709eb082c3c556","name":"GetConnect","func":"const connect = msg.payload.match(/(?<=var key= )\\d+/);\nreturn { payload: '{\"a\":' + connect[0] + '}' };","outputs":1,"timeout":"","noerr":0,"initialize":"","finalize":"","libs":[],"x":430,"y":400,"wires":[["05ec2d2f88203ac5"]]},{"id":"05ec2d2f88203ac5","type":"websocket out","z":"aa40d03efc6fc57a","g":"07709eb082c3c556","name":"Url","server":"","client":"acd3849ff684a7d3","x":590,"y":400,"wires":[]},{"id":"acd3849ff684a7d3","type":"websocket-client","path":"wss://","tls":"621bc3fe.d747dc","wholemsg":"false","hb":"0","subprotocol":""},{"id":"621bc3fe.d747dc","type":"tls-config","name":"","cert":"","key":"","ca":"","certname":"","keyname":"","caname":"","servername":"","verifyservercert":false,"alpnprotocol":""}]

You might need to share differences between yours and theirs in terms of Node Version and Node RED version (we know theirs is Node 20 according to your note)

There could be other factors to - such as is Node RED being run behind some exotic layer (HA, Docker)

FWIW : it runs fine for me (Bare-metal, 3.1, 18.14)

I am running node v18.12.1 and 3.1 for the dashboard. I did some research into Trixie and it is not considered a stable release. The guys machine is a pc running debian Trixie.


We resolved the issue. Apparently the http request node did not play well with Node.js v 20.x The user downgraded to v18.x and the flow worked as advertised.

Can you reproduce that?

It may be somewhat important if so.

@knolleary @Steve-Mcl

I will upgrade to Node.js v 20.x. The guy in Australia was also running Debian Trixie on a AMD PC. I guess there is a possibility it could be an influence. We did test the http fetch using Curl and it worked. I will get back.

1 Like

So I have been working with this guy using Node.js v18 on my pc. I just logged into my Pi and realized it is on v20.8 It works fine on raspberry pi buster running node.js v20.8

pi@Deskpi:/etc $ cat os-release
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION="10 (buster)"

At this point it is one of 2 issues. Either the Trixie release or he was doing something else wrong. Apologizes for the confusion.

He did advise that when he downgraded to v18 the flow started to work.