InfluxDB on a Raspberry Pi

#1

This is not strictly Node-Red related but I know that several people here are using InfluxDB on a Raspberry Pi in conjunction with Grafana to store data created/extracted by Node-Red.

I discovered accidentally that InfuxDB was using a very high amount of CPU time and after a bit of searching I found that this is due to InfluxDB’s internal monitoring function. This is used for diagnosis of internal errors and can safely be turned off by changing an entry in:

/etc/influxdb/influxdb.conf

Simply set
[monitor]
store-enabled = true
to
[monitor]
store-enabled = false
to disable it.

Restart InfluxDB.

Simply check the InfluxDB usage with top or htop beforehand to see if you are affected by this.

2 Likes

Ras Pi supply voltage