Inject node payload

I'm trying to use an inject node to send a simple True and another to send false at a certain time. It's not working. I have the node set to payload, repeat at a specific time, and made sure that my Pi in in the correct time zone. if I hit the tab on the side if the node it send message to the debug node. If wait for the time setting nothing. Any suggestions would be great.
Here is the Flows

Inside the node

Where are you running Node-RED?
Have you checked that the time of the machine running Node-RED matched the timezone you are in?

Thank you for the advice, but yes I did.

"and made sure that my Pi in in the correct time zone"

Please restart Node-RED and post the startup log.

Let me know if this the correct information. Thank you again!-

To find more nodes and example flows - go to

Starting as a systemd service.

Started Node-RED graphical event wiring tool.

3 Jul 08:32:17 - [info]

Welcome to Node-RED


3 Jul 08:32:18 - [info] Node-RED version: v0.20.5

3 Jul 08:32:18 - [info] Node.js version: v10.15.3

3 Jul 08:32:18 - [info] Linux 4.14.98+ arm LE

3 Jul 08:32:28 - [info] Loading palette nodes

3 Jul 08:33:04 - [info] Dashboard version 2.14.0 started at /ui

3 Jul 08:33:11 - [info] Settings file : /home/pi/.node-red/settings.js

3 Jul 08:33:11 - [info] Context store : 'default' [module=memory]

3 Jul 08:33:11 - [info] User directory : /home/pi/.node-red

3 Jul 08:33:11 - [warn] Projects disabled : editorTheme.projects.enabled=false

3 Jul 08:33:11 - [info] Flows file : /home/pi/.node-red/flows_Garden_Bed_1.json

3 Jul 08:33:13 - [warn]


Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials

file will not be recoverable, you will have to delete it and re-enter

your credentials.

You should set your own key using the 'credentialSecret' option in

your settings file. Node-RED will then re-encrypt your credentials

file using your chosen key the next time you deploy a change.


3 Jul 08:33:13 - [info] Starting flows

3 Jul 08:33:22 - [info] Started flows

3 Jul 08:33:22 - [info] Server now running at

3 Jul 08:33:23 - [info] [mqtt-broker:c5c9580d.04686] Connected to broker: mqtt:/

Why have you called it "On at 6am" but set it to repeat at 08:06?

Also, what do you see if you run, in a terminal on the PI

I seen that but looking at his log time stamps I guess he's been tweaking the time to see if it works.

I'd suggest the OP double checks he has properly deployed the flow after tweaking the time.

If it does turn out to be a bug, then perhaps he could try one of the Cron nodes (search Cron in pallete manager and install) - I used it with good success recently. (unfortunately I'm out of the country ATM so can't check which one).

One other thing, as it was set for 6am, could it be that you were in bed and the browser was not open?

Debug only works with browser open.

Are you certain the event didn't occur? It could be it did but nodes beyond the inject didn't work as expected?

I was working on the node and had it set to inject at the next minutes time. It's named 6 am so I know what the node is supposed to do, like a post it note. I was up and waiting! it should turn on the fountain and leave it on until the other node, off at 10:00, tell it to turn off. I'll look at the cron things I sure would like to use the inject nodes, I have 7 Pi's doing various things and I hate updating all of them.

thank you all

Colin - I was trouble shooting the node, its faster to change the time of the event to the current time than wait 24 hours to see if the changes are working. The name of the node is a note to myself so I know what the node its doing. Its a larger flow and I like to name all of the nodes as a best practice so I know what the intention was when I made it.

When I run date I get the current time and date for my location.

rebooted all pi's and now it works. This was just a weird glitch I guess. Thank you all for the assistance.