Install Node-RED on Alibaba Cloud Service but doesn't work

Hallo Sir,

I'm try install Node-RED to Ubuntu 16.04 on Alibaba cloud service.
I will use the method to add node-red to the system path like so:

sudo npm install -g --unsafe-perm node-red


As a rule, avoid using npm 1.x for the installation because it is not suitable for the process. To upgrade to version 2, run the command below:

root@iZk1ab7zg8omuutv9jwtbyZ:~# sudo npm install -gnpm@2.x
sudo: unable to resolve host iZk1ab7zg8omuutv9jwtbyZ
npm WARN enoent ENOENT: no such file or directory, open '/root/package.json'
npm WARN root No description
npm WARN root No repository field.
npm WARN root No README data
npm WARN root No license field.

root@iZk1ab7zg8omuutv9jwtbyZ:~# sudo ufw allow 1880
sudo: unable to resolve host iZk1ab7zg8omuutv9jwtbyZ
Skipping adding existing rule
Skipping adding existing rule (v6)

root@iZk1ab7zg8omuutv9jwtbyZ:~# node-red
gambar

But it's doesn't work, What should be correction?

Thank you Sir

What version of node is on that server?

The error suggests you have too old a version for Node-RED to run.

You need node 12 or later.

This is npm, node, nodejs version

I'm install node red on ubuntu following this link
https://www.alibabacloud.com/blog/deploy-iot-applications-with-node-red-on-alibaba_595281

How to install node 12 Sir?

The document you have linked to was written in August 2019, it is now very out of date.

Ubuntu 16.04 went end of life in April 2021 (Ubuntu release cycle | Ubuntu) , you REALLY should not be deploying anything new on it.

If you really can't change it to something newer, then you need to look at the https://nodejs.org website for instructions on how to install something MUCH newer than v4.x

Hallo Sir,

Thank you for your suggestion, the first think I will try to update nodejs with new version, if still not solved, will reset image OS system with Ubuntu 20.04.

If you can start with Ubuntu 20.04 then our install script should work. Running on Raspberry Pi : Node-RED

2 Likes