Install on Centos 7 question

Can Node-Red be installed on centos 7 or Ubuntu? I have tried installing it apprx. 20 times and it says installed but I can never bring it up with my browser, it says cant be found.

I have production instances running on both of those platforms.

1 Like

Is the browser running on the same machine as Node-RED? Are you sure that the NR host is being addressed properly?

I am running it on a VPS not local computer. In my browser I put http://my vps ip:1880

Are you sure that the VPS has port 1880 open?

1 Like

It will not be open if the VPS is any good at all. There should be a host firewall running that blocks all inbound connections (maybe excepting the SSH port and ports 80/443).

It is even possible that the ISP running the VPS host may block some ports with their own firewalls but generally I've never found an issue with that. Some block common VPN ports or ToR and Torrent if that is against local laws or their own T's & C's.

1 Like

I have re-installed ubuntu 18-04 plain and installed Node-Red, started it and used command line to open port 1880 and still cannot connect to it. When I installed NR it gave me a URL which I tried and did not work. I then substituted my server IP with :1880 tacked on and still no luck. I tried my domain name with :1880 and no connection. I can install Grafana and it works just not NR. I used UFW allow 1880 in my SSH and it seems to take but still does not connect.

In a terminal run


and post the output you get here.

"Command not found"

But if I use just node-red I get the following:

Welcome to Node-RED

Did you use the recommended install script for Ubuntu (and other Debian based distros including Raspbian) as in

If I use just node-red I get the following:
Welcome to Node-RED

12 Mar 21:09:06 - [info] Node-RED version: v1.0.4
12 Mar 21:09:06 - [info] Node.js version: v8.10.0
12 Mar 21:09:06 - [info] Linux 4.15.0-45-generic x64 LE
12 Mar 21:09:07 - [info] Loading palette nodes
12 Mar 21:09:07 - [info] Settings file : /root/.node-red/settings.js
12 Mar 21:09:07 - [info] Context store : 'default' [module=memory]
12 Mar 21:09:07 - [info] User directory : /root/.node-red
12 Mar 21:09:07 - [warn] Projects disabled : editorTheme.projects.enabled=false
12 Mar 21:09:07 - [info] Flows file : /root/.node-red/
12 Mar 21:09:07 - [info] Creating new flow file
12 Mar 21:09:08 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

12 Mar 21:09:08 - [info] Starting flows
12 Mar 21:09:08 - [info] Started flows
12 Mar 21:09:08 - [error] Unable to listen on
12 Mar 21:09:08 - [error] Error: port in use

The error port in use means that you probably already have node-red running.
However, I see that you seem to have installed it as root. So if I understand correctly you currently have node red running as root (which means it can access absolutely anything on your system) with port 1880 open to the internet. If so you may well have been hacked already. I suggest you stop the system re-install it and start again.
There are bots running on the internet looking for machines with port 1880 open and hacking into them for nefarious purposes. That is bad enough if you are running as a normal user, but as root that is catastrophic.

And I mean re-install the system, not node-red.

1 Like

Thanks, I will re-install Ubuntu and try again and post the results.

I found the problem. I installed Vesta so I could edit the firewall and add port 1880 and it worked. Sudo UFW command to open the port did not work.

As I said, don't open node-red to the internet unless you have enabled https and at least basic user/pwd login. Otherwise you will more than likely get hacked.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.