Installing Node-Red on work windows machine

But if the OP only installs python, they wont get c++ comilation tools needed for ...

I run a Node-RED instance with WSL2 in Windows 10, you can also use the EXEC node in it to start Windows programs if needed.

But maybe your employer doesn't allow WSL2 on your work PC either.

WSL2 is useful for testing Linuxy things on Windows and running some things that don't run on Windows directly but Node.js is perfectly happy running directly under Windows so you don't really need to add WSL's overheads for running Node-RED.

I tried (npm install --global windows-build-tools) but as my picture showed earlier I had warnings and I waited over 30min and still did not install build tools using this command. Outside of getting approval to use Chocolatey with the default Node.js installation I am not sure what to do and I think the WSL2 option will open up another can of worms with my IT department.

Did you not simply run the node.js install with the box ticked to "Automatically install the necessary tools"?

No, because the first time I did this my IT team notified me that Chocolatey is not allowed so i was trying the npm command for build tools. My IT team is working on an exception or some kind of work around so I hope they can get this figured out.

But the straight windows installer version doesn't use Chocolatey. You can just download and run it if you have the ability to run msi files which I thought you'd said you did (local admin).

Download | Node.js (nodejs.org)

No, i don't think it does (not 100% certain) however, if you want build tools - you get chocolatey.

What I said earlier in the thread is probably the OPs best option...

Sorry, but I set up a new PC earlier this year and used the msi file and did not install windows-build-tools. Nor do I have choco on my PC. So the msi install absolutely does give you an option to install the appropriate required tools simply by selection the option when installing.

To recap again. You only need the MSI file, nothing else. Installing Python separately is only if you want to be using Python for other things. windows-build-tools is deprecated by the author for the reasons given above. You do not need choco at all and I strongly recommend against it.

We might be having crossed wires.

I was agreeing that the installer doesn't use choco ...

I was agreeing with you & saying saying if the OP wants build tools (when checking the install tools option) - they will also get chocolatey along with it (as it says in the dialog)


Perhaps I wasn't clear. I'll try to be explicit...

The OP wants node-red & will use modbus (i.e. serial port) so therefore will need build tools. So my suggestion was install build tools with node js installer. The OP said he can't because it installs choco so I said don't use it or use the old npm script.

Not sure why your response mentions you installed without build tools & did not get choco - I know this & it says so I'm the dialog?!?!

Crossed wires I think.


100% agree.

Maybe it has changed:

Right, here is another alternative if we aren't getting anywhere.

Install the official Python Windows. Find the Microsoft Visual Studio Build Tools on the Microsoft website and download/install the exe/msi (I can't remember which).

In fact, follow the instructions here. Personally, I don't recommend the Store version of Python but if this is all you want it for, it is fine.

node-gyp - npm (npmjs.com)


On Windows

Install the current version of Python from the Microsoft Store package.

Install tools and configuration manually:

If the above steps didn't work for you, please visit Microsoft's Node.js Guidelines for Windows for additional tips.


PS: Not sure if you need to follow any of the rest of those instructions on config of Python, I'd try without first

PPS: The instructions on Microsoft's page are out of date. Python v3 is certainly supported and Python v2 is no longer supported.

I had exactly the same issues with my foot-dragging Operations guys taking their stance from pure FUD about OSS software.

I the end after many obscure but failed attempts getting a running NR-IDE running directly on my laptop, i opted for podman and ran it as a container. (weirdly enough that was easier to get through the red tape dept)

Maybe that could be an alternative approach for you?

/Jan